diff mbox series

[bug#43663] : Use system icu4c for Icecat and fix a small bug.

Message ID d3b812c.457d.174d328250f.Coremail.all_but_last@163.com
State Accepted
Headers show
Series [bug#43663] : Use system icu4c for Icecat and fix a small bug. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Zhu Zihao Sept. 28, 2020, 5:20 a.m. UTC
From f06dbc5e269efad5c726fc7cca951481304b0a7c Mon Sep 17 00:00:00 2001
From: Zhu Zihao <all_but_last@163.com>
Date: Mon, 28 Sep 2020 13:15:14 +0800
Subject: [PATCH 1/2] gnu: icecat: Use system icu4c.

* gnu/packages/gnuzilla.scm(icecat)

[native-inputs]: Add icu4c-64.
[arguments]<configure-flags>: Add "--with-system-icu".
---
 gnu/packages/gnuzilla.scm | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

--
2.28.0

Comments

Mark H Weaver Sept. 28, 2020, 7:01 p.m. UTC | #1
I pushed these to 'master', with minor changes to the commit messages,
as commits f0648a4b675c4951856ab9fbb414f8edc7ddfb54 and
981cdc901179d8feb4bdde5eefe1930ce32bb0d0.

   Thank you!
      Mark
diff mbox series

Patch

diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index 85ad9678d0..877f85db37 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -751,7 +751,7 @@  from forcing GEXP-PROMISE."
        ("libffi" ,libffi)
        ("ffmpeg" ,ffmpeg)
        ;; UNBUNDLE-ME! ("libvpx" ,libvpx)
-       ;; UNBUNDLE-ME! ("icu4c" ,icu4c)
+       ("icu4c" ,icu4c-67)
        ("pixman" ,pixman)
        ("pulseaudio" ,pulseaudio)
        ("mesa" ,mesa)
@@ -854,8 +854,8 @@  from forcing GEXP-PROMISE."
                            ;; UNBUNDLE-ME! "--with-system-vorbis"
                            ;; UNBUNDLE-ME! "--with-system-theora" ; wants theora-1.2, not yet released
                            ;; UNBUNDLE-ME! "--with-system-libvpx"
-                           ;; UNBUNDLE-ME! "--with-system-icu"
-                           
+                           "--with-system-icu"
+
                            ;; See <https://bugs.gnu.org/32833>
                            ;;   and related comments in the
                            ;;   'remove-bundled-libraries' phase below.
--
2.28.0





From bbde65267b6d48b54cc3ace41395c4dad54a7fae Mon Sep 17 00:00:00 2001
From: Zhu Zihao <all_but_last@163.com>
Date: Mon, 28 Sep 2020 13:16:48 +0800
Subject: [PATCH 2/2] gnu: icecat: Remove duplicated find-files

* gnu/packages/gnuzilla.scm(icecat)[arguments]<phases>:

In patch-cargo-checksums phase, replace "find-files" call with already found
file name.
---
 gnu/packages/gnuzilla.scm | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index 877f85db37..5d9158689a 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -1012,7 +1012,7 @@  from forcing GEXP-PROMISE."
              (let ((null-hash "e3b0c44298fc1c149afbf4c8996fb92427ae41e4649b934ca495991b7852b855"))
                (for-each (lambda (file)
                            (format #t "patching checksums in ~a~%" file)
-                           (substitute* (find-files "." "Cargo.lock$")
+                           (substitute* file
                              (("^checksum = \".*\"")
                               (string-append "checksum = \"" null-hash "\""))))
                          (find-files "." "Cargo.lock$"))