diff mbox series

[bug#60184] gnu: Add nginx-module-vts.

Message ID d2b4c003fd540defd0fb68893009b592064c34bd.1671404449.git.mirai@makinata.eu
State New
Headers show
Series [bug#60184] gnu: Add nginx-module-vts. | expand

Commit Message

Bruno Victal Dec. 18, 2022, 11:01 p.m. UTC
From: Bruno Victal <mirai@makinata.eu>

Depends on nginx http_stub_status_module.

* gnu/packages/web.scm (nginx-module-vts): New variable.
(nginx)[arguments]: Add "--with-http_stub_status_module" to #:configure-flags.
---
 gnu/packages/web.scm | 53 ++++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 53 insertions(+)


base-commit: d083809c8048a64f71a40f0657c217c9dd230428

Comments

Ludovic Courtès Jan. 26, 2023, 9:53 a.m. UTC | #1
mirai@makinata.eu skribis:

> From: Bruno Victal <mirai@makinata.eu>
>
> Depends on nginx http_stub_status_module.
>
> * gnu/packages/web.scm (nginx-module-vts): New variable.
> (nginx)[arguments]: Add "--with-http_stub_status_module" to #:configure-flags.

Applied, thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index dcb7b3872a..2ad53c7627 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -59,6 +59,7 @@ 
 ;;; Copyright © 2022 Pradana Aumars <paumars@courrier.dev>
 ;;; Copyright © 2022 Petr Hodina <phodina@protonmail.com>
 ;;; Copyright © 2022 jgart <jgart@dismail.de>
+;;; Copyright © 2022 Bruno Victal <mirai@makinata.eu>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -410,6 +411,7 @@  (define-public nginx
               "--with-debug"
               "--with-stream"
               "--with-stream_ssl_module"
+              "--with-http_stub_status_module"
               ;; Even when not cross-building, we pass the
               ;; --crossbuild option to avoid customizing for the
               ;; kernel version on the build machine.
@@ -834,6 +836,57 @@  (define-public nginx-rtmp-module
 stream.  Remote control of the module is possible over HTTP.")
     (license license:bsd-2)))
 
+(define-public nginx-module-vts
+  (package
+    (inherit nginx)
+    (name "nginx-module-vts")
+    (version "0.2.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/vozlt/nginx-module-vts")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "017298vpp1ra16xyfdbsczdrz0b0y67x6adkzcc98y6gb3kg52n7"))))
+    (build-system gnu-build-system)
+    (inputs
+     `(("nginx-sources" ,(package-source nginx))
+       ,@(package-inputs nginx)))
+    (arguments
+     (substitute-keyword-arguments
+         `(#:make-flags '("modules") ;Only build this module not all of nginx.
+           ,@(package-arguments nginx))
+       ((#:configure-flags flags)
+        #~(cons "--add-dynamic-module=." #$flags))
+       ((#:phases phases)
+        #~(modify-phases #$phases
+            (add-after 'unpack 'unpack-nginx-sources
+              (lambda _
+                (begin
+                  ;; The nginx source code is part of the module’s source.
+                  (format #t "decompressing nginx source code~%")
+                  (invoke "tar" "xvf" #$(this-package-input "nginx-sources")
+                          ;; This package's LICENSE file would be
+                          ;; overwritten with the one from nginx when
+                          ;; unpacking the nginx source, so rename the nginx
+                          ;; one when unpacking.
+                          "--transform=s,/LICENSE$,/LICENSE.nginx,"
+                          "--strip-components=1"))))
+            (replace 'install
+              (lambda _
+                (let ((modules-dir (string-append #$output
+                                                  "/etc/nginx/modules")))
+                  (install-file "objs/ngx_http_vhost_traffic_status_module.so" modules-dir))))
+            (delete 'fix-root-dirs)
+            (delete 'install-man-page)))))
+    (home-page "https://github.com/vozlt/nginx-module-vts")
+    (synopsis "NGINX module for monitoring virtual host traffic status")
+    (description "This NGINX module provides access to virtual host status information,
+similar to live activity monitoring provided with NGINX plus.")
+    (license license:bsd-2)))
+
 (define-public lighttpd
   (package
     (name "lighttpd")