diff mbox series

[bug#42457] gnu: knights: Fix build.

Message ID d2b48dcc-5882-ffef-d530-b11ff3f561d4@gmail.com
State Accepted
Headers show
Series [bug#42457] gnu: knights: Fix build. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Jesse Gibbons July 21, 2020, 6:11 a.m. UTC
* gnu/packages/games.scm (knights):
[make-flags] add "CXXFLAGS=-lpthread"
---
gnu/packages/games.scm | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)

Comments

Oleg Pykhalov July 25, 2020, 12:16 p.m. UTC | #1
Hi,

Jesse Gibbons <jgibbons2357@gmail.com> writes:

> * gnu/packages/games.scm (knights):
> [make-flags] add "CXXFLAGS=-lpthread"
> ---
> gnu/packages/games.scm | 3 ++-
> 1 file changed, 2 insertions(+), 1 deletion(-)
>
> diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
> index cff1c0af99..dc0511e55a 100644
> --- a/gnu/packages/games.scm
> +++ b/gnu/packages/games.scm
> @@ -1366,7 +1366,8 @@ built-in level editor.")
> (build-system gnu-build-system)
> (arguments
> '(#:make-flags
> - (list (string-append "PREFIX=" (assoc-ref %outputs "out")))
> + (list (string-append "PREFIX=" (assoc-ref %outputs "out"))
> + "CXXFLAGS=-lpthread")
> #:phases
> (modify-phases %standard-phases
> ;; No configure script.

This patch looks broken for me, could you resend it, please?

Thanks,
Oleg.
diff mbox series

Patch

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index cff1c0af99..dc0511e55a 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -1366,7 +1366,8 @@  built-in level editor.")
(build-system gnu-build-system)
(arguments
'(#:make-flags
- (list (string-append "PREFIX=" (assoc-ref %outputs "out")))
+ (list (string-append "PREFIX=" (assoc-ref %outputs "out"))
+ "CXXFLAGS=-lpthread")
#:phases
(modify-phases %standard-phases
;; No configure script.