diff mbox

[bug#47513,00/12] Update jami and add jami-qt

Message ID d2af8975e88f7377f1322a5a1e3ce052219cf40b.camel@telenet.be
State Accepted
Headers show

Commit Message

M April 1, 2021, 11:10 a.m. UTC
On Wed, 2021-03-31 at 01:14 -0400, Maxim Cournoyer wrote:
> Hello!
> 
> I've finally picked up the packaging of Jami, which was becoming quite
> outdated in Guix.  I haven't had much time to test the result yet, but a
> priori it seems to function as intended.
> 
> Let me know how it works for you!

It seems to work for me, however I needed to make a tiny change:

<start snip>
<end snip>

Looking at "git grep -F deprecated-package" output, perhaps

 (deprecated-package jami jami-gnome)

should have been

 (deprecated-package "jami" jami-gnome)

? (untested)

Also, I didn't have any opportunity to actually call someone.

Greetings,
Maxime.

Comments

Maxim Cournoyer April 2, 2021, 11:52 a.m. UTC | #1
Hi Maxime!

Maxime Devos <maximedevos@telenet.be> writes:

> On Wed, 2021-03-31 at 01:14 -0400, Maxim Cournoyer wrote:
>> Hello!
>> 
>> I've finally picked up the packaging of Jami, which was becoming quite
>> outdated in Guix.  I haven't had much time to test the result yet, but a
>> priori it seems to function as intended.
>> 
>> Let me know how it works for you!
>
> It seems to work for me, however I needed to make a tiny change:
>
> <start snip>
> diff --git a/gnu/packages/jami.scm b/gnu/packages/jami.scm
> index 67befe63a2..b73ad027fe 100644
> --- a/gnu/packages/jami.scm
> +++ b/gnu/packages/jami.scm
> @@ -554,7 +554,7 @@ decentralized calling using P2P-DHT.")
>  
>  ;;; Keep this until the Qt client matures enough to become the
>  ;;; main 'jami' client.
> -(deprecated-package jami jami-gnome)
> +#;(deprecated-package jami jami-gnome)
>  
>  (define-public jami-qt
>    (package
> <end snip>

Jack in the thread made me notice about that as well; deprecated-package
returns a package object, so it needs to be public-define'd the usual
way:

+
+;;; Keep this until the Qt client matures enough to become the
+;;; main 'jami' client.
+(define-public jami
+  (deprecated-package "jami" jami-gnome))

And yes the package name is a string.  I fixed this in a v2 patch series
I sent along a problem propagating libringclient instead of libring for
the jami-qt client (see:
https://debbugs.gnu.org/cgi/bugreport.cgi?bug=47513#95).  MUMI
(issues.guix.gnu.org) sadly doesn't seem to have picked it up.

[...]

> Also, I didn't have any opportunity to actually call someone.

[...]

OK!  I've tested it on my side with actual calls, so I feel confident it
works fine.  I've made a few last changes (using LIBWRAP when building
libringclient so that it talks directly with libring instead of going
through DBus, which allows to have it work even in a 'guix pack' and
cleaning the list of imports) and pushed to master as
e6b447cf756831e8339e6462647004d88132fa07.

Thanks for the review!

Maxim
diff mbox

Patch

diff --git a/gnu/packages/jami.scm b/gnu/packages/jami.scm
index 67befe63a2..b73ad027fe 100644
--- a/gnu/packages/jami.scm
+++ b/gnu/packages/jami.scm
@@ -554,7 +554,7 @@  decentralized calling using P2P-DHT.")
 
 ;;; Keep this until the Qt client matures enough to become the
 ;;; main 'jami' client.
-(deprecated-package jami jami-gnome)
+#;(deprecated-package jami jami-gnome)
 
 (define-public jami-qt
   (package