diff mbox series

[bug#55424,3/4] gnu: python-pygame-sdl2: Update to 2.1.0-0-1705c6e.

Message ID d293d6e39376bc2562f1ceac956c1aadf8d4109b.camel@gmail.com
State Accepted
Headers show
Series None | expand

Commit Message

Liliana Marie Prikler June 17, 2022, 8:26 a.m. UTC
* gnu/packages/game-development.scm (python-pygame-sdl2): Update to
2.1.0-0-1705c6e.
---
 gnu/packages/game-development.scm | 24 ++++++++++--------------
 1 file changed, 10 insertions(+), 14 deletions(-)

Comments

Maxim Cournoyer June 17, 2022, 1:36 p.m. UTC | #1
Hi again,

Liliana Marie Prikler <liliana.prikler@gmail.com> writes:

> * gnu/packages/game-development.scm (python-pygame-sdl2): Update to
> 2.1.0-0-1705c6e.
> ---
>  gnu/packages/game-development.scm | 24 ++++++++++--------------
>  1 file changed, 10 insertions(+), 14 deletions(-)
>
> diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
> index 44f8ca57fc..ea83450995 100644
> --- a/gnu/packages/game-development.scm
> +++ b/gnu/packages/game-development.scm
> @@ -1207,26 +1207,22 @@ (define-public python-pygame
>                     license:lgpl2.1+))))
>  
>  (define-public python-pygame-sdl2
> +  ;; Using nightly from 2022-06-16.
> +  ;; Revert back to URLs once renpy 8 is released!
>    (let ((real-version "2.1.0")
> -        (renpy-version "7.4.11"))
> +        ;;(renpy-version "8.0.0")
> +        (commit "1705c6e3004dcb1daf859560bcd52eb093e97d45"))
>      (package
>        (inherit python-pygame)
>        (name "python-pygame-sdl2")
> -      (version (string-append real-version "-for-renpy-" renpy-version))
> +      (version (git-version real-version "0" commit))
>        (source
>         (origin
> -         (method url-fetch)
> -         (uri (string-append "https://www.renpy.org/dl/" renpy-version
> -                             "/pygame_sdl2-" version ".tar.gz"))
> -         (sha256 (base32 "0nxvca16299jx6sp0ys29rqixcs21ymhqwjfkbchhss0yar7qjgz"))
> -         (modules '((guix build utils)))
> -         (snippet
> -          '(begin
> -             ;; drop generated sources
> -             (delete-file-recursively "gen")
> -             (delete-file-recursively "gen3")
> -             (delete-file-recursively "gen-static")
> -             #t))))
> +         (method git-fetch)
> +         (uri (git-reference
> +               (url "https://github.com/renpy/pygame_sdl2")
> +               (commit commit)))
> +         (sha256 (base32
>  "1g0arhpd59zypspk36sgajf1kzavppfkv766vifvxar60968rrjn"))))

You'll wan to keep the (file-name ...) argument, otherwise 'guix lint'
complains about it:

gnu/packages/game-development.scm:1220:7: python-pygame-sdl2@2.1.0-0.1705c6e: the source file name should contain the package name
gnu/packages/game-development.scm:1215:4: python-pygame-sdl2@2.1.0-0.1705c6e: can be upgraded to 7.4.9.2112

Perhaps the version should still read '2.1.0-for-renpy-7.9.9' to match the
pseudo-version used for renpy.

Otherwise, LGTM!

Thanks,

Maxim
diff mbox series

Patch

diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 44f8ca57fc..ea83450995 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -1207,26 +1207,22 @@  (define-public python-pygame
                    license:lgpl2.1+))))
 
 (define-public python-pygame-sdl2
+  ;; Using nightly from 2022-06-16.
+  ;; Revert back to URLs once renpy 8 is released!
   (let ((real-version "2.1.0")
-        (renpy-version "7.4.11"))
+        ;;(renpy-version "8.0.0")
+        (commit "1705c6e3004dcb1daf859560bcd52eb093e97d45"))
     (package
       (inherit python-pygame)
       (name "python-pygame-sdl2")
-      (version (string-append real-version "-for-renpy-" renpy-version))
+      (version (git-version real-version "0" commit))
       (source
        (origin
-         (method url-fetch)
-         (uri (string-append "https://www.renpy.org/dl/" renpy-version
-                             "/pygame_sdl2-" version ".tar.gz"))
-         (sha256 (base32 "0nxvca16299jx6sp0ys29rqixcs21ymhqwjfkbchhss0yar7qjgz"))
-         (modules '((guix build utils)))
-         (snippet
-          '(begin
-             ;; drop generated sources
-             (delete-file-recursively "gen")
-             (delete-file-recursively "gen3")
-             (delete-file-recursively "gen-static")
-             #t))))
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/renpy/pygame_sdl2")
+               (commit commit)))
+         (sha256 (base32 "1g0arhpd59zypspk36sgajf1kzavppfkv766vifvxar60968rrjn"))))
       (build-system python-build-system)
       (arguments
        `(#:tests? #f                ; tests require pygame to be installed first