diff mbox series

[bug#53512] gnu: QGIS: Build without QtWebKit.

Message ID d27a8c912d218a917989416d4181b999c37a6784.1643055300.git.leo@famulari.name
State Accepted
Headers show
Series [bug#53512] gnu: QGIS: Build without QtWebKit. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Leo Famulari Jan. 24, 2022, 8:15 p.m. UTC
See <https://issues.guix.gnu.org/53289> for more information about this change.

With this change, the build fails due to some tests timing out.

I don't use QGIS, so it's not easy for me to understand the problem or
if it's okay to add tese tests to the long list of disabled tests. I
also could not find any online discussion about these tests timing out.

* gnu/packages/geo.scm (qgis)[inputs]: Remove qtwebkit.
[arguments]: Pass "-DWITH_QTWEBKIT=NO" to #:configure-flags.
---
 gnu/packages/geo.scm | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

Comments

Guillaume Le Vaillant Jan. 25, 2022, 11:05 a.m. UTC | #1
Leo Famulari <leo@famulari.name> skribis:

> See <https://issues.guix.gnu.org/53289> for more information about this change.
>
> With this change, the build fails due to some tests timing out.
>
> I don't use QGIS, so it's not easy for me to understand the problem or
> if it's okay to add tese tests to the long list of disabled tests. I
> also could not find any online discussion about these tests timing out.
>
> * gnu/packages/geo.scm (qgis)[inputs]: Remove qtwebkit.
> [arguments]: Pass "-DWITH_QTWEBKIT=NO" to #:configure-flags.
> ---
>  gnu/packages/geo.scm | 3 ++-
>  1 file changed, 2 insertions(+), 1 deletion(-)
>
> diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
> index 287b157b60..05591b7ce7 100644
> --- a/gnu/packages/geo.scm
> +++ b/gnu/packages/geo.scm
> @@ -2274,6 +2274,8 @@ (define-public qgis
>         #:imported-modules (,@%cmake-build-system-modules
>                             (guix build python-build-system)
>                             (guix build qt-utils))
> +       #:configure-flags
> +       '("-DWITH_QTWEBKIT=NO")
>         #:phases
>         (modify-phases %standard-phases
>           ;; Configure correct path to PyQt5 SIP directory
> @@ -2490,7 +2492,6 @@ (define-public qgis
>             qtlocation
>             qtserialport
>             qtsvg
> -           qtwebkit
>             qwt
>             ;;("saga" ,saga)
>             sqlite))

It looks like the failing tests are trying to do some HTML rendering,
which requires QtWebKit I suppose. But why is the test suite trying to
run these tests if QtWebKit is explicitly disabled?

The 'check' phase currently doesn't take the 'tests?' keyword parameter
into consideration. Maybe you could add that to your patch.

After disabling the tests, I tried a few things, like loading some
OpenStreetMap data from a database and making a map with it, and
I didn't see any issue. So I think you can add the failing tests to the
list of disabled tests.
Leo Famulari Jan. 25, 2022, 6:40 p.m. UTC | #2
On Tue, Jan 25, 2022 at 11:05:50AM +0000, Guillaume Le Vaillant wrote:
> It looks like the failing tests are trying to do some HTML rendering,
> which requires QtWebKit I suppose. But why is the test suite trying to
> run these tests if QtWebKit is explicitly disabled?

That is indeed the question. I'd guess that using QGIS without QtWebKit
is not well exercised upstream.

> The 'check' phase currently doesn't take the 'tests?' keyword parameter
> into consideration. Maybe you could add that to your patch.

Sure, thanks for noticing that.

> After disabling the tests, I tried a few things, like loading some
> OpenStreetMap data from a database and making a map with it, and
> I didn't see any issue. So I think you can add the failing tests to the
> list of disabled tests.

Okay, thanks for checking. I'll test a revised patch and push once it
builds.
Leo Famulari Jan. 25, 2022, 8:11 p.m. UTC | #3
On Tue, Jan 25, 2022 at 01:40:25PM -0500, Leo Famulari wrote:
> Okay, thanks for checking. I'll test a revised patch and push once it
> builds.

Pushed as 4235c6ee92b5c8875343c675c8d841eaa9f40d4c.

I did forget to adjust the indentation of the test phase... oh well.
diff mbox series

Patch

diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 287b157b60..05591b7ce7 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -2274,6 +2274,8 @@  (define-public qgis
        #:imported-modules (,@%cmake-build-system-modules
                            (guix build python-build-system)
                            (guix build qt-utils))
+       #:configure-flags
+       '("-DWITH_QTWEBKIT=NO")
        #:phases
        (modify-phases %standard-phases
          ;; Configure correct path to PyQt5 SIP directory
@@ -2490,7 +2492,6 @@  (define-public qgis
            qtlocation
            qtserialport
            qtsvg
-           qtwebkit
            qwt
            ;;("saga" ,saga)
            sqlite))