diff mbox series

[bug#61799] gnu: Add ruby-minima.

Message ID d25da4ac3cca6c3a581371ba3a902c015c858550.1677387126.git.gemmaro.dev@gmail.com
State New
Headers show
Series [bug#61799] gnu: Add ruby-minima. | expand

Commit Message

gemmaro Feb. 26, 2023, 5:02 a.m. UTC
Hello,

This patch adds the Minima Jekyll theme.
It has no dependents other than itself,
and can be used with jekyll and ruby packages.

Best regards,
gemmaro.

* gnu/packages/ruby.scm (ruby-minima): New variable.
---
 gnu/packages/ruby.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)


base-commit: a7c7363a825e176ae25f5f69cacfff0880b23e80

Comments

gemmaro May 3, 2023, 2:37 a.m. UTC | #1
Hello Ruby team,

I'm sorry.  I should have added X-Debbugs-Cc to mention, since this
patch is about ruby.scm.

Regards,
gemmaro.
diff mbox series

Patch

diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 2e8d4038de..6a75e1cb0f 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -31,6 +31,7 @@ 
 ;;; Copyright © 2022 Philip McGrath <philip@philipmcgrath.com>
 ;;; Copyright © 2022 Remco van 't Veer <remco@remworks.net>
 ;;; Copyright © 2022 Taiju HIGASHI <higashi@taiju.info>
+;;; Copyright © 2023 gemmaro <gemmaro.dev@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -4320,6 +4321,28 @@  (define-public ruby-net-scp
     (home-page "https://github.com/net-ssh/net-scp")
     (license license:expat)))
 
+(define-public ruby-minima
+  (package
+    (name "ruby-minima")
+    (version "2.5.1")
+    (source (origin
+              (method url-fetch)
+              (uri (rubygems-uri "minima" version))
+              (sha256
+               (base32
+                "1gk7jmriiswda1ykjzpsw9cpiya4m9n0yrh0h6xnrc8zcfy543jj"))))
+    ;; Minima doesn't have tests.
+    (arguments
+     `(#:tests? #f))
+    (build-system ruby-build-system)
+    (propagated-inputs (list jekyll ruby-jekyll-feed ruby-jekyll-seo-tag))
+    (synopsis "Beautiful, minimal theme for Jekyll")
+    (description
+     "Minima is a one-size-fits-all Jekyll theme for writers.  It's Jekyll's
+default (and first) theme.  It's what you get when you run @code{jekyll new}.")
+    (home-page "https://github.com/jekyll/minima")
+    (license license:expat)))
+
 (define-public ruby-minitest
   (package
     (name "ruby-minitest")