diff mbox series

[bug#68986] gnu: Add libsixel.

Message ID d248c977016a45289e2a132405066d02418ccf94.1707349785.git.chris@bumblehead.com
State New
Headers show
Series [bug#68986] gnu: Add libsixel. | expand

Commit Message

chris Feb. 7, 2024, 11:49 p.m. UTC
*  (libsixel): New variable.

The libsixel install was verified with this command: img2sixel myimg.png

Curl is disabled to mitigate CVE-2021-45340 guix lint warns about.

Change-Id: I7c8077dd705409ce914ab347115d0b4fddeb37e1
---
 gnu/packages/image.scm | 35 +++++++++++++++++++++++++++++++++++
 1 file changed, 35 insertions(+)


base-commit: 5d2302a1959d09e6d5a5f02ac199458095847a82

Comments

Nicolas Goaziou Feb. 22, 2024, 8:01 p.m. UTC | #1
Hello,

chris <chris@bumblehead.com> writes:

> *  (libsixel): New variable.
>
> The libsixel install was verified with this command: img2sixel myimg.png
>

Thank you!

I fixed the commit message, tweaked the description, sorted inputs
alphabetically, and applied your patch.


Regards,
diff mbox series

Patch

diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 1f434667f8..85b70087be 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -38,6 +38,7 @@ 
 ;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
 ;;; Copyright © 2023-2024 Nicolas Goaziou <mail@nicolasgoaziou.fr>
 ;;; Copyright © 2023 Artyom V. Poptsov <poptsov.artyom@gmail.com>
+;;; Copyright © 2024 chris <chris@bumblehead.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -2816,3 +2817,37 @@  (define-public spng
    (license license:bsd-2)
    ;; Supports SSE on x86-64 and NEON on AArch64.
    (properties '((tunable? . #t)))))
+
+(define-public libsixel
+  (package
+    (name "libsixel")
+    (version "1.10.3")
+    (home-page "https://github.com/libsixel/libsixel")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url home-page)
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1nny4295ipy4ajcxmmh04c796hcds0y7z7rv3qd17mj70y8j0r2d"))))
+    (build-system meson-build-system)
+    (arguments
+     (list
+      #:build-type "release"
+      #:configure-flags #~'("--buildtype=plain" "-Dtests=enabled"
+                            "-Dlibcurl=disabled" "-Dgdk-pixbuf2=enabled")))
+    (native-inputs (list pkg-config))
+    (inputs (list libjpeg-turbo libpng python gdk-pixbuf))
+    (synopsis
+     "Provides encoder/decoder implementation for DEC SIXEL graphics.")
+    (description
+     "@command{libpixel} is a an encoder/decoder implementation
+ for DEC SIXEL graphics, and some converter programs. SIXEL is
+ one of image formats for printer and terminal imaging introduced
+ by Digital Equipment Corp. (DEC).  Its data scheme is represented
+ as a terminal-friendly escape sequence. So if you want to view a
+ SIXEL image file, all you have to do is \"cat\" it to your
+ terminal")
+    (license license:expat)))