diff mbox series

[bug#63453,v2,2/3] gnu: python-ipython-documentation: Remove patches.

Message ID d2308da225df1e4ba7a28d33351b93db258b7329.1684785831.git.code@greghogan.com
State New
Headers show
Series Fix build for python-ipython-documentation. | expand

Commit Message

Greg Hogan May 22, 2023, 8:17 p.m. UTC
* gnu/packages/python-xyz.scm (python-ipython-documentation)[source]:
Remove upstreamed patches.
* gnu/packages/patches/python-ipython-documentation-chars.patch,
gnu/packages/patches/python-ipython-documentation-repro.patch:
Delete files.
* gnu/local.mk: Remove files.
---
 gnu/local.mk                                  |  2 --
 .../python-ipython-documentation-chars.patch  | 18 -------------
 .../python-ipython-documentation-repro.patch  | 25 -------------------
 gnu/packages/python-xyz.scm                   |  7 ------
 4 files changed, 52 deletions(-)
 delete mode 100644 gnu/packages/patches/python-ipython-documentation-chars.patch
 delete mode 100644 gnu/packages/patches/python-ipython-documentation-repro.patch
diff mbox series

Patch

diff --git a/gnu/local.mk b/gnu/local.mk
index b5d43d7203..e0f195c0fb 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1785,8 +1785,6 @@  dist_patch_DATA =						\
   %D%/packages/patches/python-fixtures-remove-monkeypatch-test.patch	\
   %D%/packages/patches/python-hiredis-fix-header.patch		\
   %D%/packages/patches/python-hiredis-use-system-hiredis.patch	\
-  %D%/packages/patches/python-ipython-documentation-chars.patch	\
-  %D%/packages/patches/python-ipython-documentation-repro.patch	\
   %D%/packages/patches/python-keras-integration-test.patch	\
   %D%/packages/patches/python-pdoc3-tests.patch			\
   %D%/packages/patches/python-peachpy-determinism.patch	\
diff --git a/gnu/packages/patches/python-ipython-documentation-chars.patch b/gnu/packages/patches/python-ipython-documentation-chars.patch
deleted file mode 100644
index a52c54f513..0000000000
--- a/gnu/packages/patches/python-ipython-documentation-chars.patch
+++ /dev/null
@@ -1,18 +0,0 @@ 
-Avoid LaTeX errors due to non-printable characters.
-Submitted upstream: https://github.com/ipython/ipython/pull/13640
-
-diff --git a/IPython/utils/coloransi.py b/IPython/utils/coloransi.py
-index e33142180..9300b0108 100644
---- a/IPython/utils/coloransi.py
-+++ b/IPython/utils/coloransi.py
-@@ -74,8 +74,8 @@ class TermColors:
- class InputTermColors:
-     """Color escape sequences for input prompts.
- 
--    This class is similar to TermColors, but the escapes are wrapped in \001
--    and \002 so that readline can properly know the length of each line and
-+    This class is similar to TermColors, but the escapes are wrapped in \\001
-+    and \\002 so that readline can properly know the length of each line and
-     can wrap lines accordingly.  Use this class for any colored text which
-     needs to be used in input prompts, such as in calls to raw_input().
- 
diff --git a/gnu/packages/patches/python-ipython-documentation-repro.patch b/gnu/packages/patches/python-ipython-documentation-repro.patch
deleted file mode 100644
index d6a6e9c3fd..0000000000
--- a/gnu/packages/patches/python-ipython-documentation-repro.patch
+++ /dev/null
@@ -1,25 +0,0 @@ 
-Fix non-reproducibilities caused by time-dependent procedures.
-Submitted upstream: https://github.com/ipython/ipython/pull/13640
-
-diff --git a/IPython/sphinxext/ipython_directive.py b/IPython/sphinxext/ipython_directive.py
-index 18bdfcae9..2c665ac87 100644
---- a/IPython/sphinxext/ipython_directive.py
-+++ b/IPython/sphinxext/ipython_directive.py
-@@ -19,7 +19,7 @@
-    In [1]: 1+1
- 
-    In [1]: import datetime
--      ...: datetime.datetime.now()
-+      ...: datetime.date.fromisoformat('2022-02-22')
- 
- It supports IPython construct that plain
- Python does not understand (like magics):
-@@ -28,7 +28,7 @@
- 
-    In [0]: import time
- 
--   In [0]: %timeit time.sleep(0.05)
-+   In [0]: %pdoc time
- 
- This will also support top-level async when using IPython 7.0+
- 
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 1f5f937e6c..162e103cbc 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -10418,13 +10418,6 @@  (define-public python-ipython-documentation
     (inherit python-ipython)
     (name "python-ipython-documentation")
     (version (package-version python-ipython))
-    (source
-     (origin
-       (inherit (package-source python-ipython))
-       (patches (append (search-patches
-                         "python-ipython-documentation-chars.patch"
-                         "python-ipython-documentation-repro.patch")
-                        (origin-patches (package-source python-ipython))))))
     (arguments
      (list
       #:phases