diff mbox series

[bug#39365,1/6] gnu: Add qrcodegen-cpp.

Message ID d1b35284d66dbed5e4fa09dd0f6a658ba0f0a1ef.1580439985.git.leo@famulari.name
State Accepted
Headers show
Series [bug#39365,1/6] gnu: Add qrcodegen-cpp. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Leo Famulari Jan. 31, 2020, 3:06 a.m. UTC
* gnu/packages/aidc.scm (qrcodegen-cpp): New variable.
---
 gnu/packages/aidc.scm | 39 +++++++++++++++++++++++++++++++++++++++
 1 file changed, 39 insertions(+)

Comments

Efraim Flashner Jan. 31, 2020, 8:58 a.m. UTC | #1
On Thu, Jan 30, 2020 at 10:06:22PM -0500, Leo Famulari wrote:
> * gnu/packages/aidc.scm (qrcodegen-cpp): New variable.
> ---
>  gnu/packages/aidc.scm | 39 +++++++++++++++++++++++++++++++++++++++
>  1 file changed, 39 insertions(+)

You're missing the actual patch ;)

> 
> diff --git a/gnu/packages/aidc.scm b/gnu/packages/aidc.scm
> index 77db0ac9fc..b68f2137be 100644
> --- a/gnu/packages/aidc.scm
> +++ b/gnu/packages/aidc.scm
> @@ -4,6 +4,7 @@
>  ;;; Copyright © 2017 Hartmut Goebel <h.goebel@crazy-compilers.com>
>  ;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
>  ;;; Copyright © 2019 Guillaume Le Vaillant <glv@posteo.net>
> +;;; Copyright © 2020 Leo Famulari <leo@famulari.name>
>  ;;;
>  ;;; This file is part of GNU Guix.
>  ;;;
> @@ -154,3 +155,41 @@ For application developers, language bindings are included for C, C++ and
>  Python as well as GUI widgets for GTK and Qt.")
>      (home-page "https://github.com/mchehab/zbar")
>      (license license:lgpl2.1+)))
> +
> +(define-public qrcodegen-cpp
> +  ;; Currently this project's installation mechanism only exists as a GitHub
> +  ;; pull request, so we build from a recent commit that the proposed patch
> +  ;; applies to.
> +  (let ((commit "6ea933f1596d818bd21e9a6b8d2e851fb8b4bcf1")
> +        (revision "0"))
> +    (package
> +      (name "qrcodegen-cpp")
> +      (version (git-version "1.5.0" revision commit))
> +      (source (origin
> +                (method git-fetch)
> +                (uri (git-reference
> +                       (url "https://github.com/nayuki/QR-Code-generator.git")
> +                       (commit commit)))
> +                (file-name (git-file-name name version))
> +                (patches (search-patches "qrcodegen-cpp-make-install.patch"))
> +                (sha256
> +                 (base32
> +                  "19fcwqmfk2n9p2n01dv2j4x2y2mqip0j1wbmfbxjp34rqkjwcwxm"))))
> +      (build-system gnu-build-system)
> +      (arguments
> +       `(#:tests? #f ; no test suite
> +         #:make-flags
> +         (list (string-append "PREFIX=" (assoc-ref %outputs "out")))
> +         #:phases
> +         (modify-phases %standard-phases
> +           (delete 'configure) ; No ./configure script
> +           ;; Only build the C++ variant.
> +           (add-after 'unpack 'chdir
> +             (lambda _
> +               (chdir "cpp")
> +               #t)))))
> +      (synopsis "QR Code generator library")
> +      (description "qrcodegen-cpp is a QR code generator library in C++.  The
> +project also offers Java, Javascript, Python, C, and Rust implementations.")

You can drop the comma after C if you want.

> +      (home-page "https://www.nayuki.io/page/qr-code-generator-library")
> +      (license license:expat))))
> -- 
> 2.25.0
> 
> 
> 
>
Jonathan Brielmaier Jan. 31, 2020, 11:42 p.m. UTC | #2
----- Ursprüngliche Mitteilung -----
> * gnu/packages/aidc.scm (qrcodegen-cpp): New variable.
> ---
>   gnu/packages/aidc.scm | 39 +++++++++++++++++++++++++++++++++++++++
>   1 file changed, 39 insertions(+)
> 
> diff --git a/gnu/packages/aidc.scm b/gnu/packages/aidc.scm
> index 77db0ac9fc..b68f2137be 100644
> --- a/gnu/packages/aidc.scm
> +++ b/gnu/packages/aidc.scm
> @@ -4,6 +4,7 @@
>   ;;; Copyright © 2017 Hartmut Goebel <h.goebel@crazy-compilers.com>
>   ;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
>   ;;; Copyright © 2019 Guillaume Le Vaillant <glv@posteo.net>
> +;;; Copyright © 2020 Leo Famulari <leo@famulari.name>
>   ;;;
>   ;;; This file is part of GNU Guix.
>   ;;;
> @@ -154,3 +155,41 @@ For application developers, language bindings are
> included for C, C++ and Python as well as GUI widgets for GTK and Qt.")
>           (home-page "https://github.com/mchehab/zbar")
>           (license license:lgpl2.1+)))
> +
> +(define-public qrcodegen-cpp
> +   ;; Currently this project's installation mechanism only exists as a
> GitHub +   ;; pull request, so we build from a recent commit that the
> proposed patch +   ;; applies to.
> +   (let ((commit "6ea933f1596d818bd21e9a6b8d2e851fb8b4bcf1")
> +               (revision "0"))
> +       (package
> +           (name "qrcodegen-cpp")
> +           (version (git-version "1.5.0" revision commit))
> +           (source (origin
> +                               (method git-fetch)
> +                               (uri (git-reference
> +                                             (url
> "https://github.com/nayuki/QR-Code-generator.git") +                                       
>     (commit commit))) +                               (file-name (git-file-name name
> version)) +                               (patches (search-patches
> "qrcodegen-cpp-make-install.patch")) +                               (sha256
> +                                 (base32
> +                                 

I think you forgot to include the patch and adding it to lokal.mk.

> "19fcwqmfk2n9p2n01dv2j4x2y2mqip0j1wbmfbxjp34rqkjwcwxm")))) +         
> (build-system gnu-build-system) +           (arguments
> +             `(#:tests? #f ; no test suite
> +                 #:make-flags
> +                 (list (string-append "PREFIX=" (assoc-ref %outputs "out")))
> +                 #:phases
> +                 (modify-phases %standard-phases
> +                     (delete 'configure) ; No ./configure script
> +                     ;; Only build the C++ variant.
> +                     (add-after 'unpack 'chdir
> +                         (lambda _
> +                             (chdir "cpp")
> +                             #t)))))
> +           (synopsis "QR Code generator library")
> +           (description "qrcodegen-cpp is a QR code generator library in
> C++.   The +project also offers Java, Javascript, Python, C, and Rust
> implementations.") +           (home-page
> "https://www.nayuki.io/page/qr-code-generator-library") +           (license
> license:expat)))) -- 
> 2.25.0
> 
> 
> 
>
Ludovic Courtès Feb. 13, 2020, 10:21 p.m. UTC | #3
Hi,

Efraim Flashner <efraim@flashner.co.il> skribis:

>> +      (description "qrcodegen-cpp is a QR code generator library in C++.  The
>> +project also offers Java, Javascript, Python, C, and Rust implementations.")
>
> You can drop the comma after C if you want.

Actually no, it would have a different meaning, from what I learned
(namely, the last part would mean “implementations in/of C and Rust”,
instead of “implementations in/of Rust”.)

More importantly though: apart from the missing patch and ‘gnu/local.mk’
bit that were reported, the series LGTM.

Thanks, Leo!

Ludo’.
Leo Famulari Feb. 14, 2020, 1:13 a.m. UTC | #4
On Thu, Feb 13, 2020 at 11:21:27PM +0100, Ludovic Courtès wrote:
> Hi,
> 
> Efraim Flashner <efraim@flashner.co.il> skribis:
> 
> >> +      (description "qrcodegen-cpp is a QR code generator library in C++.  The
> >> +project also offers Java, Javascript, Python, C, and Rust implementations.")
> >
> > You can drop the comma after C if you want.
> 
> Actually no, it would have a different meaning, from what I learned
> (namely, the last part would mean “implementations in/of C and Rust”,
> instead of “implementations in/of Rust”.)
> 
> More importantly though: apart from the missing patch and ‘gnu/local.mk’
> bit that were reported, the series LGTM.
> 
> Thanks, Leo!

Thanks for the reminder about these patches! Pushed as 1ce2467fd6d5f8da259be1c7609702814c716702
diff mbox series

Patch

diff --git a/gnu/packages/aidc.scm b/gnu/packages/aidc.scm
index 77db0ac9fc..b68f2137be 100644
--- a/gnu/packages/aidc.scm
+++ b/gnu/packages/aidc.scm
@@ -4,6 +4,7 @@ 
 ;;; Copyright © 2017 Hartmut Goebel <h.goebel@crazy-compilers.com>
 ;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2019 Guillaume Le Vaillant <glv@posteo.net>
+;;; Copyright © 2020 Leo Famulari <leo@famulari.name>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -154,3 +155,41 @@  For application developers, language bindings are included for C, C++ and
 Python as well as GUI widgets for GTK and Qt.")
     (home-page "https://github.com/mchehab/zbar")
     (license license:lgpl2.1+)))
+
+(define-public qrcodegen-cpp
+  ;; Currently this project's installation mechanism only exists as a GitHub
+  ;; pull request, so we build from a recent commit that the proposed patch
+  ;; applies to.
+  (let ((commit "6ea933f1596d818bd21e9a6b8d2e851fb8b4bcf1")
+        (revision "0"))
+    (package
+      (name "qrcodegen-cpp")
+      (version (git-version "1.5.0" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                       (url "https://github.com/nayuki/QR-Code-generator.git")
+                       (commit commit)))
+                (file-name (git-file-name name version))
+                (patches (search-patches "qrcodegen-cpp-make-install.patch"))
+                (sha256
+                 (base32
+                  "19fcwqmfk2n9p2n01dv2j4x2y2mqip0j1wbmfbxjp34rqkjwcwxm"))))
+      (build-system gnu-build-system)
+      (arguments
+       `(#:tests? #f ; no test suite
+         #:make-flags
+         (list (string-append "PREFIX=" (assoc-ref %outputs "out")))
+         #:phases
+         (modify-phases %standard-phases
+           (delete 'configure) ; No ./configure script
+           ;; Only build the C++ variant.
+           (add-after 'unpack 'chdir
+             (lambda _
+               (chdir "cpp")
+               #t)))))
+      (synopsis "QR Code generator library")
+      (description "qrcodegen-cpp is a QR code generator library in C++.  The
+project also offers Java, Javascript, Python, C, and Rust implementations.")
+      (home-page "https://www.nayuki.io/page/qr-code-generator-library")
+      (license license:expat))))