diff mbox series

[bug#48283] gnu: mercurial: Update to 5.8.

Message ID d13a96c5866521918b944256a1a7539f56974292.1620474779.git.public@yoctocell.xyz
State Accepted
Headers show
Series [bug#48283] gnu: mercurial: Update to 5.8. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Xinglu Chen May 8, 2021, 11:53 a.m. UTC
* gnu/packages/version-control.scm (mercurial): Update to 5.8.
[build-system]: Switch from ‘python-build-system’ to ‘gnu-build-system’, this
will install additional things like man pages.
[arguments]<#:make-flags>: Set PREFIX argument.
[native-inputs]: Add ‘python-docutils’ for generating man pages.
[inputs]: Add ‘python’.
[description]: Fix formatting.
---
 gnu/packages/version-control.scm | 24 +++++++++++++++---------
 1 file changed, 15 insertions(+), 9 deletions(-)


base-commit: e5adaf6c2de917f33f90e24b551a8991e55b3eb6

Comments

Efraim Flashner May 15, 2021, 7:49 p.m. UTC | #1
Pushed by Ludovic as bdb6ff3ab13c94ae5b51171c4f1df87f8af398cc. Thanks!
diff mbox series

Patch

diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 0cad83c4b0..b5c7800e12 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -1638,18 +1638,21 @@  execution of any hook written in any language before every commit.")
 (define-public mercurial
   (package
     (name "mercurial")
-    (version "5.6.1")
+    (version "5.8")
     (source (origin
              (method url-fetch)
              (uri (string-append "https://www.mercurial-scm.org/"
                                  "release/mercurial-" version ".tar.gz"))
              (sha256
               (base32
-               "1bgz8f1a7lnmh6lzcvwg6q1yx6i7yibhwy06l4k55i04957jap75"))))
-    (build-system python-build-system)
+               "17rhlmmkqz5ll3k68jfzpcifg3nndbcbc2nx7kw8xn3qcj7nlpgw"))))
+    (build-system gnu-build-system)
     (arguments
-     `(#:phases
+     `(#:make-flags
+       (list (string-append "PREFIX=" (assoc-ref %outputs "out")))
+       #:phases
        (modify-phases %standard-phases
+         (delete 'configure)
          (add-after 'unpack 'patch-tests
            (lambda _
              (substitute* '("tests/test-extdiff.t"
@@ -1702,17 +1705,20 @@  execution of any hook written in any language before every commit.")
                          ;; The test suite takes a long time and produces little
                          ;; output by default.  Prevent timeouts due to silence.
                          "-v"))))))))
-    ;; The following inputs are only needed to run the tests.
     (native-inputs
-     `(("python-nose" ,python-nose)
+     `(("python-docutils", python-docutils)
+       ;; The following inputs are only needed to run the tests.
+       ("python-nose" ,python-nose)
        ("unzip" ,unzip)
        ("which" ,which)))
+    (inputs
+     `(("python" ,python)))
     (home-page "https://www.mercurial-scm.org/")
     (synopsis "Decentralized version control system")
     (description
-     "Mercurial is a free, distributed source control management tool.
-It efficiently handles projects of any size
-and offers an easy and intuitive interface.")
+     "Mercurial is a free, distributed source control management tool.  It
+efficiently handles projects of any size and offers an easy and intuitive
+interface.")
     (license license:gpl2+)))
 
 (define-public python-hg-evolve