diff mbox series

[bug#60480,2/2] gnu: plover: Add dbus to inputs

Message ID d1392b204dd78dcffbb18b17807158f5eb062cd3.1672504941.git.poomklao@yahoo.com
State New
Headers show
Series gnu: plover: Fix missing icons + dbus | expand

Commit Message

Parnikkapore Jan. 2, 2023, 1:08 a.m. UTC
* gnu/packages/stenography.scm (plover): Add dbus to inputs and LD_LIBRARY_PATH
  Plover tries to load dbus during startup (visible with --log-level debug).
  This will allow it to find it.
---
 gnu/packages/stenography.scm | 8 +++++++-
 1 file changed, 7 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/gnu/packages/stenography.scm b/gnu/packages/stenography.scm
index 3249ee4c4f..e4617031fd 100644
--- a/gnu/packages/stenography.scm
+++ b/gnu/packages/stenography.scm
@@ -27,6 +27,7 @@  (define-module (gnu packages stenography)
   #:use-module (guix packages)
   #:use-module (gnu packages)
   #:use-module (gnu packages bash)
+  #:use-module (gnu packages glib)
   #:use-module (gnu packages qt)
   #:use-module (gnu packages check)
   #:use-module (gnu packages libusb)
@@ -87,10 +88,15 @@  (define-public plover
                                               ,(list (string-append (assoc-ref
                                                                      inputs
                                                                      "qtsvg")
-                                                      "/lib/qt5/plugins/"))))))))))
+                                                      "/lib/qt5/plugins/")))
+                                            `("LD_LIBRARY_PATH" prefix
+                                              (,(string-append (assoc-ref
+                                                                inputs "dbus")
+                                                               "/lib/"))))))))))
     (native-inputs (list python-babel python-mock python-pytest
                          python-pytest-qt python-pytest-xvfb))
     (inputs (list bash-minimal
+                  dbus
                   python-appdirs
                   python-dbus
                   python-hidapi