diff mbox series

[bug#46618] gnu: webrtc-for-telegram-desktop: Fix segmentation fault in telegram-desktop.

Message ID d04dc9c7-f93d-1aa7-7742-5d2a4ee5f060@raghavgururajan.name
State Accepted
Headers show
Series [bug#46618] gnu: webrtc-for-telegram-desktop: Fix segmentation fault in telegram-desktop. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Raghav Gururajan Feb. 18, 2021, 5:22 p.m. UTC

Comments

Leo Prikler Feb. 18, 2021, 8:24 p.m. UTC | #1
Pushed with a small change in the commit message.  Also
Am Donnerstag, den 18.02.2021, 12:22 -0500 schrieb Raghav Gururajan:
> +        `(("gcc" ,gcc-9)
I've added a comment to keep this in line with telegram-desktop, so
hopefully the bug won't show up again.

Thanks a lot!
Leo
Raghav Gururajan Feb. 18, 2021, 8:25 p.m. UTC | #2
Hi Leo!

> Pushed with a small change in the commit message.  Also
> Am Donnerstag, den 18.02.2021, 12:22 -0500 schrieb Raghav Gururajan:
>> +        `(("gcc" ,gcc-9)
> I've added a comment to keep this in line with telegram-desktop, so
> hopefully the bug won't show up again.

Thanks a lot!

Regards,
RG.
diff mbox series

Patch

From 2a7f83cc5eb2e1235d5e39d7b58929351d902d0f Mon Sep 17 00:00:00 2001
From: Raghav Gururajan <rg@raghavgururajan.name>
Date: Thu, 18 Feb 2021 11:23:16 -0500
Subject: [PATCH] gnu: webrtc-for-telegram-desktop: Fix segmentation fault in
 telegram-desktop.

* gnu/packages/telegram.scm (webrtc-for-telegram-desktop) [native-inputs]: Add gcc-9 and perl.
---
 gnu/packages/telegram.scm | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)

diff --git a/gnu/packages/telegram.scm b/gnu/packages/telegram.scm
index 2430242241..661d390dbf 100644
--- a/gnu/packages/telegram.scm
+++ b/gnu/packages/telegram.scm
@@ -126,7 +126,9 @@ 
                   (copy-recursively libyuv-from libyuv-to))
                 #t)))))
        (native-inputs
-        `(("pkg-config" ,pkg-config)
+        `(("gcc" ,gcc-9)
+          ("perl" ,perl)
+          ("pkg-config" ,pkg-config)
           ("python" ,python-wrapper)
           ("yasm" ,yasm)))
        (inputs
-- 
2.30.1