diff mbox series

[bug#73128,gnome-team,v2,09/13] gnu: xdg-desktop-portal: Improve style.

Message ID d0431b3b08ef8f2665653d406363f764744501e3.1726213021.git.liliana.prikler@gmail.com
State New
Headers show
Series [bug#73128,gnome-team,v2,01/13] gnu: orca: Update to 46.2. | expand

Commit Message

Liliana Marie Prikler Sept. 13, 2024, 7:37 a.m. UTC
* gnu/packages/freedesktop.scm (xdg-desktop-portal) [inputs]: Move after
arguments.  Drop labels.
[native-inputs]: Move after inputs.  Drop labels.
---
 gnu/packages/freedesktop.scm | 40 ++++++++++++++++++------------------
 1 file changed, 20 insertions(+), 20 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index e593bf4ebb..d539e5fe31 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -3053,26 +3053,6 @@  (define-public xdg-desktop-portal
        ;; Disable portal tests since they try to use fuse.
        (patches (search-patches "xdg-desktop-portal-disable-portal-tests.patch"))))
     (build-system meson-build-system)
-    (native-inputs
-     `(("pkg-config" ,pkg-config)
-       ("glib:bin" ,glib "bin")
-       ("gettext" ,gettext-minimal)
-       ("python" ,python)
-       ("python-dbusmock" ,python-dbusmock)
-       ("python-pytest" ,python-pytest)
-       ("python-pytest-xdist" ,python-pytest-xdist)))
-    (inputs
-     `(("bubblewrap" ,bubblewrap)
-       ("gdk-pixbuf" ,gdk-pixbuf)
-       ("glib" ,glib)
-       ("flatpak" ,flatpak)
-       ("fontconfig" ,fontconfig)
-       ("json-glib" ,json-glib)
-       ("libportal" ,libportal)
-       ("dbus" ,dbus)
-       ("geoclue" ,geoclue)
-       ("pipewire" ,pipewire)
-       ("fuse" ,fuse)))
     (arguments
      `(#:configure-flags
        (list "-Dsystemd=disabled")
@@ -3086,6 +3066,26 @@  (define-public xdg-desktop-portal
                        (find-files "po" "\\.po$"))))
          (add-after 'unpack 'set-home-directory
            (lambda _ (setenv "HOME" "/tmp"))))))
+    (inputs
+     (list bubblewrap
+           dbus
+           flatpak
+           fontconfig
+           fuse
+           gdk-pixbuf
+           geoclue
+           glib
+           json-glib
+           libportal
+           pipewire))
+    (native-inputs
+     (list gettext-minimal
+           `(,glib "bin")
+           pkg-config
+           python
+           python-dbusmock
+           python-pytest
+           python-pytest-xdist))
     (native-search-paths
      (list (search-path-specification
             (variable "XDG_DESKTOP_PORTAL_DIR")