diff mbox series

[bug#49576] Add sterm

Message ID cvMzjxFjTYD2u4Yu7O9VDuG0eCwLJ6B563cZq2ZcVC7R1kFbNlE7uKAtM83pRbsG30NMilIgAXw3DXeHA4T_e-h6P-HPSGhu6ZMIIoVhqS4=@protonmail.com
State Accepted
Headers show
Series [bug#49576] Add sterm | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

phodina July 17, 2021, 12:08 p.m. UTC
Thanks Tobias. Now it builds without errors.

Yes, I used Nix.

Here's the updated patch:
---
index 4429a2b75a..e0eb92967c 100644
--
2.31.1

Comments

宋文武 July 18, 2021, 9:42 a.m. UTC | #1
phodina <phodina@protonmail.com> writes:

> Thanks Tobias. Now it builds without errors.
>
> Yes, I used Nix.
>
> Here's the updated patch:
> [...]

Pushed, thank you and Tobias!
diff mbox series

Patch

--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -1297,6 +1297,36 @@  replacement for the OpenDWG libraries.")
     (description "@code{minicom} is a serial terminal emulator.")
     (license license:gpl2+)))

+(define-public sterm
+(package
+  (name "sterm")
+  (version "20200306")
+  (source (origin
+            (method git-fetch)
+            (uri (git-reference
+                  (url "https://github.com/wentasah/sterm")
+                  (commit version)))
+            (file-name (git-file-name name version))
+            (sha256
+             (base32
+              "031pd8yz2bfzqbari6za1c3xcqmw94ap4vbrjzb3v6izjcrca58c"))))
+  (build-system gnu-build-system)
+  (arguments
+    `(#:tests? #f ; no tests
+      #:make-flags
+       (list (string-append "CC=" ,(cc-for-target))
+             (string-append "PREFIX=" %output))
+      #:phases
+      (modify-phases %standard-phases (delete 'configure))))
+  (synopsis "Simple serial terminal")
+  (description "This is a minimalist terminal program like minicom or cu.
+The only thing it does is creating a bidirectional connection between
+stdin/stdout and a terminal device (e.g. serial line).
+It can also set serial line baudrate, manipulate DTR/RTS modem lines,
+send break and throttle transmission speed.")
+  (home-page "https://github.com/wentasah/sterm")
+  (license license:gpl3+)))
+
 (define-public harminv
   (package
     (name "harminv")