[bug#33401] gnu: Add font-manager.

Message ID cucmuqaf15w.fsf@Vague.i-did-not-set--mail-host-address--so-tickle-me
State Accepted
Headers show
Series [bug#33401] gnu: Add font-manager. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

L p R n d n Nov. 15, 2018, 9:07 p.m. UTC
---
 gnu/packages/fontutils.scm | 50 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 50 insertions(+)

Comments

Marius Bakke April 2, 2020, 4:04 p.m. UTC | #1
Lprndn <guix@lprndn.info> writes:

> ---
>  gnu/packages/fontutils.scm | 50 ++++++++++++++++++++++++++++++++++++++
>  1 file changed, 50 insertions(+)

A variant of this patch was added in
ad8aaf47f50e3b0360b8c27557753333ae44ad5f.  Apologies for the duplicate
work, don't be afraid to bump the tracker after a few weeks to prevent
patches from falling through the cracks!

Patch

diff --git a/gnu/packages/fontutils.scm b/gnu/packages/fontutils.scm
index 09ba9b7e4..01073afeb 100644
--- a/gnu/packages/fontutils.scm
+++ b/gnu/packages/fontutils.scm
@@ -42,7 +42,10 @@ 
   #:use-module (gnu packages gperf)
   #:use-module (gnu packages xorg)
   #:use-module (gnu packages gtk)
+  #:use-module (gnu packages gnome)
   #:use-module (gnu packages xml)
+  #:use-module (gnu packages databases)
+  #:use-module (gnu packages file)
   #:use-module ((guix licenses) #:prefix license:)
   #:use-module (guix packages)
   #:use-module (guix download)
@@ -619,6 +622,53 @@  generate bitmaps.")
    (license license:gpl3+)
    (home-page "https://fontforge.github.io/en-US/")))
+(define-public font-manager
+  (package
+   (name "font-manager")
+   (version "0.7.3.1")
+   (source (origin
+            (method url-fetch)
+            (uri (string-append
+                  "https://github.com/FontManager/master/releases/download/"
+                  version "/" name "-0.7.3.tar.bz2"))
+            (sha256
+             (base32 "07316js0ggdaf834ms9f5g64n95kwihkpvs3556s4xakff60fdx0"))))
+   (build-system gnu-build-system)
+   (arguments
+    `(#:configure-flags
+      '("--with-file-roller")
+      #:phases
+      (modify-phases %standard-phases
+        (add-after 'unpack 'noconfigure
+          (lambda _
+            (setenv "NOCONFIGURE" "true")
+            #t)))))
+   (native-inputs
+    `(("pkg-config" ,pkg-config)
+      ("file" ,file)
+      ("vala" ,vala)
+      ("yelp-tools" ,yelp-tools)
+      ("intltool" ,intltool)
+      ("itstool" ,itstool)
+      ("glib" ,glib "bin")))
+   (inputs
+    `(("file-roller" ,file-roller)
+      ("libxml2" ,libxml2)
+      ("json-glib" ,json-glib)
+      ("sqlite" ,sqlite)
+      ("librsvg" ,librsvg)
+      ("gtk+" ,gtk+)
+      ("gucharmap" ,gucharmap)
+      ("libgee" ,libgee)))
+      (home-page "https://fontmanager.github.io/")
+      (synopsis "Simple font management for GTK+ desktop environments")
+      (description "Font Manager is intended to provide a way for average users to
+easily manage desktop fonts, without having to resort to command
+line tools or editing configuration files by hand.
+While designed primarily with the Gnome Desktop Environment in mind, it should
+work well with other Gtk+ desktop environments.")
+      (license license:gpl3+)))
+
 (define-public python2-ufolib
   (package
     (name "python2-ufolib")
-- 
2.19.1