[bug#33311] gnu: Drop non-sbcl lisp support from Stumpwm 2018.05.

Message ID cublg582kvc.fsf@gmx.com
State Accepted
Headers show
Series [bug#33311] gnu: Drop non-sbcl lisp support from Stumpwm 2018.05. | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied

Commit Message

Pierre Langlois Dec. 2, 2018, 12:06 p.m. UTC
Hello,

Here's the updated patch.  I've removed ecl-stumpwm but kept the pure
source cl-stumpwm variant.

Thanks!
Pierre

Comments

Oleg Pykhalov Dec. 5, 2018, 4:34 a.m. UTC | #1
Hello Pierre,

Pierre Langlois <pierre.langlois@gmx.com> writes:

> What about the pure CL source version, should I remove that one too? I
> guess it doesn't hurt to keep it.

I'm not agree to remove it because I don't understand a build system.
The build farm succeeds to “build” it as I am.  According to a build
system documentation:

     Additionally, the corresponding source package should be labeled
     using the same convention as python packages (see *note Python
     Modules::), using the ‘cl-’ prefix.

https://www.gnu.org/software/guix/manual/en/html_node/Build-Systems.html

I think you might want to start a discussion on guix-devel.

> Here's the updated patch.  I've removed ecl-stumpwm but kept the pure
> source cl-stumpwm variant.

LGTM with minor changes in commit message,
pushed as 4b193da3f959244112a85f996d630aa1ed6d0902

Thanks,
Oleg.

Patch

From bb230935bebbeaae5e8effe0383c121f2e69a3dc Mon Sep 17 00:00:00 2001
From: Pierre Langlois <pierre.langlois@gmx.com>
Date: Thu, 8 Nov 2018 09:51:05 +0000
Subject: [PATCH] gnu: stumpwm: Drop non-sbcl lisp support.

StumpWM version 1.0.0 was the last version to support lisps other than
sbcl.  This renames the current version of Stumpwm to simply "stumpwm" instead
of "sbcl-stumpwm" since it's redundant, and removes the unmaintained
ecl-stumpwm package.

* gnu/packages/lisp.scm (sbcl-stumpwm): Rename to stumpwm.  Introduce a
deprecated package for sbcl-stumpwm.
[name]: Rename to "stumpwm".
[arguments]: Set #:asd-system-name to "stumpwm".
[properties]: Replace ecl-variant with cl-source-variant.
(ecl-stumpwm): Remove.
(cl-stumpwm): Replace sbcl-stumpwm with stumpwm and adapt.
(sbcl-stumpwm+slynk): Rename to stumpwm+slynk.  Introduce a deprecated package
for sbcl-stumpwm+slynk.
[name]: Rename to "stumpwm-with-slynk".
[inherit, inputs, arguments]: Replace sbcl-stumpwm with stumpwm.
---
 gnu/packages/lisp.scm | 37 ++++++++++++++++++++-----------------
 1 file changed, 20 insertions(+), 17 deletions(-)

diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index 5e8b6fdd3d..120d0d5e17 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -11,6 +11,7 @@ 
 ;;; Copyright © 2018 Benjamin Slade <slade@jnanam.net>
 ;;; Copyright © 2018 Alex Vong <alexvong1995@gmail.com>
 ;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
+;;; Copyright © 2018 Pierre Langlois <pierre.langlois@gmx.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -928,9 +929,9 @@  from other CLXes around the net.")
      `(("sbcl-cl-ppcre" ,sbcl-cl-ppcre)
        ("sbcl-cl-unicode" ,sbcl-cl-unicode)))))
 
-(define-public sbcl-stumpwm
+(define-public stumpwm
   (package
-    (name "sbcl-stumpwm")
+    (name "stumpwm")
     (version "18.05")
     (source (origin
               (method url-fetch)
@@ -946,7 +947,8 @@  from other CLXes around the net.")
               ("alexandria" ,sbcl-alexandria)))
     (outputs '("out" "lib"))
     (arguments
-     '(#:phases
+     '(#:asd-system-name "stumpwm"
+       #:phases
        (modify-phases %standard-phases
          (add-after 'create-symlinks 'build-program
            (lambda* (#:key outputs #:allow-other-keys)
@@ -979,17 +981,15 @@  for input.  These design decisions reflect the growing popularity of
 productive, customizable lisp based systems.")
     (home-page "https://github.com/stumpwm/stumpwm")
     (license license:gpl2+)
-    (properties `((ecl-variant . ,(delay ecl-stumpwm))))))
+    (properties `((cl-source-variant . ,(delay cl-stumpwm))))))
 
-(define-public cl-stumpwm
-  (sbcl-package->cl-source-package sbcl-stumpwm))
+(define-public sbcl-stumpwm
+  (deprecated-package "sbcl-stumpwm" stumpwm))
 
-(define-public ecl-stumpwm
-  (let ((base (sbcl-package->ecl-package sbcl-stumpwm)))
-    (package
-      (inherit base)
-      (outputs '("out"))
-      (arguments '()))))
+(define-public cl-stumpwm
+  (package
+    (inherit (sbcl-package->cl-source-package stumpwm))
+    (name "cl-stumpwm")))
 
 ;; The slynk that users expect to install includes all of slynk's contrib
 ;; modules.  Therefore, we build the base module and all contribs first; then
@@ -1268,16 +1268,16 @@  multiple inspectors with independent history.")
                          paths)
             #t)))))))
 
-(define-public sbcl-stumpwm+slynk
+(define-public stumpwm+slynk
   (package
-    (inherit sbcl-stumpwm)
-    (name "sbcl-stumpwm-with-slynk")
+    (inherit stumpwm)
+    (name "stumpwm-with-slynk")
     (outputs '("out"))
     (inputs
-     `(("stumpwm" ,sbcl-stumpwm "lib")
+     `(("stumpwm" ,stumpwm "lib")
        ("slynk" ,sbcl-slynk)))
     (arguments
-     (substitute-keyword-arguments (package-arguments sbcl-stumpwm)
+     (substitute-keyword-arguments (package-arguments stumpwm)
        ((#:phases phases)
         `(modify-phases ,phases
            (replace 'build-program
@@ -1301,6 +1301,9 @@  multiple inspectors with independent history.")
            (delete 'cleanup)
            (delete 'create-symlinks)))))))
 
+(define-public sbcl-stumpwm+slynk
+  (deprecated-package "sbcl-stumpwm-with-slynk" stumpwm+slynk))
+
 (define-public sbcl-parse-js
   (let ((commit "fbadc6029bec7039602abfc06c73bb52970998f6")
         (revision "1"))
-- 
2.19.2