diff mbox series

[bug#37082] Add poussetaches

Message ID cu7o90licnr.fsf@systemreboot.net
State Accepted
Headers show
Series [bug#37082] Add poussetaches | expand

Commit Message

Arun Isaac Aug. 19, 2019, 12:04 p.m. UTC
The attached patchset adds poussetaches, a lightweight asynchronous task
execution service.

Comments

Ludovic Courtès Aug. 27, 2019, 10:31 a.m. UTC | #1
Hi Arun,

Arun Isaac <arunisaac@systemreboot.net> skribis:

> From cccbc240836acd1be7e1f1bc4eac51d1c719fd6a Mon Sep 17 00:00:00 2001
> From: Arun Isaac <arunisaac@systemreboot.net>
> Date: Mon, 19 Aug 2019 17:27:17 +0530
> Subject: [PATCH 1/2] gnu: Add go-github-com-robfig-cron.
>
> * gnu/packages/golang.scm (go-github-com-robfig-cron): New variable.

[...]

> From e0edac0d08da5845a36b05de1f8f0110540cda17 Mon Sep 17 00:00:00 2001
> From: Arun Isaac <arunisaac@systemreboot.net>
> Date: Mon, 19 Aug 2019 17:28:22 +0530
> Subject: [PATCH 2/2] gnu: Add poussetaches.
>
> * gnu/packages/web.scm (poussetaches): New variable.

Funny name.  :-)

LGTM!

Ludo’.
Arun Isaac Aug. 29, 2019, 7:56 p.m. UTC | #2
>> * gnu/packages/web.scm (poussetaches): New variable.
>
> Funny name.  :-)

:-) It apparently means "push tasks" in French.

>
> LGTM!

Pushed to master, thanks!
diff mbox series

Patch

From e0edac0d08da5845a36b05de1f8f0110540cda17 Mon Sep 17 00:00:00 2001
From: Arun Isaac <arunisaac@systemreboot.net>
Date: Mon, 19 Aug 2019 17:28:22 +0530
Subject: [PATCH 2/2] gnu: Add poussetaches.

* gnu/packages/web.scm (poussetaches): New variable.
---
 gnu/packages/web.scm | 34 ++++++++++++++++++++++++++++++++++
 1 file changed, 34 insertions(+)

diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 0b7bf698f1..205826cc9a 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -68,6 +68,7 @@ 
   #:use-module (guix build-system python)
   #:use-module (guix build-system ant)
   #:use-module (guix build-system scons)
+  #:use-module (guix build-system go)
   #:use-module (gnu packages)
   #:use-module (gnu packages admin)
   #:use-module (gnu packages adns)
@@ -92,6 +93,7 @@ 
   #:use-module (gnu packages gnome)
   #:use-module (gnu packages gnu-doc)
   #:use-module (gnu packages gnupg)
+  #:use-module (gnu packages golang)
   #:use-module (gnu packages gperf)
   #:use-module (gnu packages gtk)
   #:use-module (gnu packages guile)
@@ -6597,3 +6599,35 @@  It's also possible to rewrite existing log files.
 
 Anonip can also be uses as a Python module in your own Python application.")
     (license license:bsd-3)))
+
+(define-public poussetaches
+  (package
+    (name "poussetaches")
+    (version "0.0.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/tsileo/poussetaches")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "07106kfcz3a39jvrv3mlqqxlihsmdhgkrjnqznyjsij9absgvdv6"))))
+    (build-system go-build-system)
+    (propagated-inputs
+     `(("go-github-com-robfig-cron" ,go-github-com-robfig-cron)
+       ("go-golang-org-x-time-rate" ,go-golang-org-x-time-rate)))
+    (arguments
+     `(#:import-path "github.com/tsileo/poussetaches"))
+    (home-page "https://github.com/tsileo/poussetaches")
+    (synopsis "Lightweight asynchronous task execution service")
+    (description "Poussetaches (which literally means \"push tasks\" in
+French) is a lightweight asynchronous task execution service that aims to
+replace Celery and RabbitMQ for small Python applications.
+
+The app posts base64-encoded payload to poussetaches and specifies the
+endpoint that will be used to trigger the task.  Poussetaches makes HTTP
+requests with the registered payload until the right status code is
+returned.")
+    (license license:isc)))
-- 
2.22.0