[bug#34194] gnu: Add emacs-mkmcc-gnuplot-mode.

Message ID cu7k1it562n.fsf@systemreboot.net
State Accepted
Headers show
Series [bug#34194] gnu: Add emacs-mkmcc-gnuplot-mode. | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied

Commit Message

Arun Isaac Jan. 25, 2019, 11:29 a.m. UTC
I have packaged mkmcc's gnuplot-mode. We already have another
gnuplot-mode (bruceravel's gnuplot-mode) packaged for Guix. But
bruceravel's gnuplot-mode does not seem to be maintained. mkmcc's
gnuplot-mode is a separate project and is somewhat better
maintained. So, it could be of use to Guix users.

Comments

Marius Bakke Jan. 31, 2019, 10:22 p.m. UTC | #1
Arun Isaac <arunisaac@systemreboot.net> writes:

> I have packaged mkmcc's gnuplot-mode. We already have another
> gnuplot-mode (bruceravel's gnuplot-mode) packaged for Guix. But
> bruceravel's gnuplot-mode does not seem to be maintained. mkmcc's
> gnuplot-mode is a separate project and is somewhat better
> maintained. So, it could be of use to Guix users.

Thanks!

> * gnu/packages/emacs-xyz.scm (emacs-mkmcc-gnuplot-mode): New variable.

[...]

> +    (description "@code{emacs-mkmcc-gnuplot-mode} is a minimal emacs major
> +mode for editing gnuplot scripts.  It only provides syntax highlighting,
> +indentation and a command to plot the file.")

Maybe 's/only//'?  LGTM, anyway.
Arun Isaac Feb. 1, 2019, 7:53 p.m. UTC | #2
>> +    (description "@code{emacs-mkmcc-gnuplot-mode} is a minimal emacs major
>> +mode for editing gnuplot scripts.  It only provides syntax highlighting,
>> +indentation and a command to plot the file.")
>
> Maybe 's/only//'?  LGTM, anyway.

I made this change and pushed to master. Thanks for the review!

Patch

From 40f6d899c87923a5967a2aa9138b490e7b119229 Mon Sep 17 00:00:00 2001
From: Arun Isaac <arunisaac@systemreboot.net>
Date: Fri, 25 Jan 2019 16:52:40 +0530
Subject: [PATCH] gnu: Add emacs-mkmcc-gnuplot-mode.

* gnu/packages/emacs-xyz.scm (emacs-mkmcc-gnuplot-mode): New variable.
---
 gnu/packages/emacs-xyz.scm | 24 +++++++++++++++++++++++-
 1 file changed, 23 insertions(+), 1 deletion(-)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index bd084bd2d8..2db372fe07 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -16,7 +16,7 @@ 
 ;;; Copyright © 2016 Alex Griffin <a@ajgrf.com>
 ;;; Copyright © 2016, 2017, 2018, 2019 Nicolas Goaziou <mail@nicolasgoaziou.fr>
 ;;; Copyright © 2016, 2017, 2018 Alex Vong <alexvong1995@gmail.com>
-;;; Copyright © 2016, 2017, 2018 Arun Isaac <arunisaac@systemreboot.net>
+;;; Copyright © 2016, 2017, 2018, 2019 Arun Isaac <arunisaac@systemreboot.net>
 ;;; Copyright © 2017 Christopher Baines <mail@cbaines.net>
 ;;; Copyright © 2017, 2018 Mathieu Othacehe <m.othacehe@gmail.com>
 ;;; Copyright © 2017, 2018, 2019 Clément Lassieur <clement@lassieur.org>
@@ -12970,3 +12970,25 @@  comments.")
       (description "This package provides an Emacs major mode which acts as a
 front end to mpc, a client for the @dfn{Music Player Daemon} (MPD).")
       (license license:gpl3+))))
+
+(define-public emacs-mkmcc-gnuplot-mode
+  (package
+    (name "emacs-mkmcc-gnuplot-mode")
+    (version "1.2.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/mkmcc/gnuplot-mode")
+             (commit "601f6392986f0cba332c87678d31ae0d0a496ce7")))
+       (file-name (string-append name "-" version "-checkout"))
+       (sha256
+        (base32
+         "14f0yh1rjqc3337j4sbqzfb7pjim2c8a7wk1a73xkrdkmjn82vgb"))))
+    (build-system emacs-build-system)
+    (home-page "https://mkmcc.github.io/software/gnuplot-mode.html")
+    (synopsis "Minimal emacs major mode for editing gnuplot scripts")
+    (description "@code{emacs-mkmcc-gnuplot-mode} is a minimal emacs major
+mode for editing gnuplot scripts.  It only provides syntax highlighting,
+indentation and a command to plot the file.")
+    (license license:gpl3+)))
-- 
2.19.2