[bug#33963] gnu: octave: Fix makeinfo path configuration

Message ID cu7h8epheiq.fsf@systemreboot.net
State Accepted
Headers show
Series [bug#33963] gnu: octave: Fix makeinfo path configuration | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Arun Isaac Jan. 3, 2019, 4:50 p.m. UTC
The makeinfo path now needs to be substituted in
libinterp/corefcn/help.h, not libinterp/corefn/help.cc. I have addressed
this in the attached patch.

I have also filed a bug upstream asking them to add a configure flag
--with-makeinfo. Hopefully, we won't have to manually substitute
the path to makeinfo in the next release.

https://savannah.gnu.org/bugs/index.php?55371

Comments

Kei Kebreau Jan. 5, 2019, 3:24 a.m. UTC | #1
Arun Isaac <arunisaac@systemreboot.net> writes:

> The makeinfo path now needs to be substituted in
> libinterp/corefcn/help.h, not libinterp/corefn/help.cc. I have addressed
> this in the attached patch.
>
> I have also filed a bug upstream asking them to add a configure flag
> --with-makeinfo. Hopefully, we won't have to manually substitute
> the path to makeinfo in the next release.
>
> https://savannah.gnu.org/bugs/index.php?55371
>
> From 36612684f6f7719aef4b1b9fd40632b8749fcd90 Mon Sep 17 00:00:00 2001
> From: Arun Isaac <arunisaac@systemreboot.net>
> Date: Thu, 3 Jan 2019 21:56:26 +0530
> Subject: [PATCH] gnu: octave: Fix makeinfo path configuration.
>
> * gnu/packages/maths.scm (octave-cli)[arguments]: Fix makeinfo path
> configuration in configure-makeinfo phase.
> ---
>  gnu/packages/maths.scm | 11 +++++------
>  1 file changed, 5 insertions(+), 6 deletions(-)
>
> diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
> index 448d9e373..e67bc5e93 100644
> --- a/gnu/packages/maths.scm
> +++ b/gnu/packages/maths.scm
> @@ -19,7 +19,7 @@
>  ;;; Copyright © 2017 Nils Gillmann <ng0@n0.is>
>  ;;; Copyright © 2017 Ben Woodcroft <donttrustben@gmail.com>
>  ;;; Copyright © 2017 Theodoros Foradis <theodoros@foradis.org>
> -;;; Copyright © 2017 Arun Isaac <arunisaac@systemreboot.net>
> +;;; Copyright © 2017, 2019 Arun Isaac <arunisaac@systemreboot.net>
>  ;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
>  ;;; Copyright © 2017 Dave Love <me@fx@gnu.org>
>  ;;; Copyright © 2018 Jan Nieuwenhuizen <janneke@gnu.org>
> @@ -1484,11 +1484,10 @@ can solve two kinds of problems:
>         (modify-phases %standard-phases
>           (add-after 'configure 'configure-makeinfo
>             (lambda* (#:key inputs #:allow-other-keys)
> -             (substitute* "libinterp/corefcn/help.cc"
> -               (("Vmakeinfo_program = \"makeinfo\"")
> -                (string-append "Vmakeinfo_program = \""
> -                               (assoc-ref inputs "texinfo")
> -                               "/bin/makeinfo\"")))
> +             (substitute* "libinterp/corefcn/help.h"
> +               (("\"makeinfo\"")
> +                (string-append
> +                 "\"" (assoc-ref inputs "texinfo") "/bin/makeinfo\"")))
>               #t)))))
>      (home-page "https://www.gnu.org/software/octave/")
>      (synopsis "High-level language for numerical computation")

LGTM.
Arun Isaac Jan. 5, 2019, 6:25 p.m. UTC | #2
Pushed, thanks for the review!

Patch

From 36612684f6f7719aef4b1b9fd40632b8749fcd90 Mon Sep 17 00:00:00 2001
From: Arun Isaac <arunisaac@systemreboot.net>
Date: Thu, 3 Jan 2019 21:56:26 +0530
Subject: [PATCH] gnu: octave: Fix makeinfo path configuration.

* gnu/packages/maths.scm (octave-cli)[arguments]: Fix makeinfo path
configuration in configure-makeinfo phase.
---
 gnu/packages/maths.scm | 11 +++++------
 1 file changed, 5 insertions(+), 6 deletions(-)

diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 448d9e373..e67bc5e93 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -19,7 +19,7 @@ 
 ;;; Copyright © 2017 Nils Gillmann <ng0@n0.is>
 ;;; Copyright © 2017 Ben Woodcroft <donttrustben@gmail.com>
 ;;; Copyright © 2017 Theodoros Foradis <theodoros@foradis.org>
-;;; Copyright © 2017 Arun Isaac <arunisaac@systemreboot.net>
+;;; Copyright © 2017, 2019 Arun Isaac <arunisaac@systemreboot.net>
 ;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2017 Dave Love <me@fx@gnu.org>
 ;;; Copyright © 2018 Jan Nieuwenhuizen <janneke@gnu.org>
@@ -1484,11 +1484,10 @@  can solve two kinds of problems:
        (modify-phases %standard-phases
          (add-after 'configure 'configure-makeinfo
            (lambda* (#:key inputs #:allow-other-keys)
-             (substitute* "libinterp/corefcn/help.cc"
-               (("Vmakeinfo_program = \"makeinfo\"")
-                (string-append "Vmakeinfo_program = \""
-                               (assoc-ref inputs "texinfo")
-                               "/bin/makeinfo\"")))
+             (substitute* "libinterp/corefcn/help.h"
+               (("\"makeinfo\"")
+                (string-append
+                 "\"" (assoc-ref inputs "texinfo") "/bin/makeinfo\"")))
              #t)))))
     (home-page "https://www.gnu.org/software/octave/")
     (synopsis "High-level language for numerical computation")
-- 
2.19.2