[bug#76419] * gnu/packages/games.scm (moonlight-qt): Modify inputs.

Message ID chUyL6oH7gf38rDIwo_Uz66O1r-PqXEW3STQcbUytpn0jXGJvLck4UWYdaG-ZMrb4r88OAho_Kv9a-aGgXE3GyrNDRKDVJel8ueNWn-MTyU=@proton.me
State New
Headers
Series [bug#76419] * gnu/packages/games.scm (moonlight-qt): Modify inputs. |

Commit Message

Vitor Hugo Feb. 19, 2025, 6:17 p.m. UTC
  The package was missing `wayland` as an input, which broke hardware
acceleration whenever running under wayland. This fixes it.

Change-Id: I65b16f5e2e77627f79f45a63461436be51e0fa96
---
 gnu/packages/games.scm | 44 +++++++++++++++++++++++++-----------------
 1 file changed, 26 insertions(+), 18 deletions(-)
  

Patch

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 30aaf0767a..10fe0f6dac 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -6566,15 +6566,15 @@  (define-public moonlight-qt
   (package
     (name "moonlight-qt")
     (version "6.1.0")
-    (source (origin
-              (method git-fetch)
-              (uri (git-reference
-                    (url "https://github.com/moonlight-stream/moonlight-qt")
-                    (commit (string-append "v" version))))
-              (file-name (git-file-name name version))
-              (sha256
-               (base32
-                "06fxf3m26k036asxjkkykk5q96nincwmpiqm953m7zgr9224gidx"))))
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/moonlight-stream/moonlight-qt")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "06fxf3m26k036asxjkkykk5q96nincwmpiqm953m7zgr9224gidx"))))
     (build-system qt-build-system)
     (arguments
      (list
@@ -6583,18 +6583,25 @@  (define-public moonlight-qt
       #~(modify-phases %standard-phases
           (replace 'configure
             (lambda* _
-              (symlink (string-append
-                        #$(this-package-input "sdl2-gamecontrollerdb")
-                        "/share/sdl2/gamecontrollerdb.txt")
+              (symlink (string-append #$(this-package-input
+                                         "sdl2-gamecontrollerdb")
+                                      "/share/sdl2/gamecontrollerdb.txt")
                        "app/SDL_GameControllerDB/gamecontrollerdb.txt")
               ;; Unbundle libraries.
               (substitute* "moonlight-qt.pro"
-                (("    moonlight-common-c.*\n") "")
-                (("    qmdnsengine.*\n") "")
-                (("    h264bitstream.*\n") "")
-                (("    app \\\\") "    app")
-                (("app.depends") "INCLUDEPATH +="))
-              (invoke "qmake" (string-append "PREFIX=" #$output)))))))
+                (("    moonlight-common-c.*\n")
+                 "")
+                (("    qmdnsengine.*\n")
+                 "")
+                (("    h264bitstream.*\n")
+                 "")
+                (("    app \\\\")
+                 "    app")
+                (("app.depends")
+                 "INCLUDEPATH +="))
+              (invoke "qmake"
+                      (string-append "PREFIX="
+                                     #$output)))))))
     (native-inputs (list pkg-config qttools-5))
     (inputs (list ffmpeg
                   h264bitstream
@@ -6609,6 +6616,7 @@  (define-public moonlight-qt
                   qtquickcontrols2-5
                   qtsvg-5
                   qtwayland-5
+                  wayland
                   sdl2
                   sdl2-ttf
                   sdl2-gamecontrollerdb))