diff mbox series

[bug#64909] * gnu/packages/game-development.scm (godot) [arguments, inputs]: use system brotli

Message ID cfff80a9a30b1ddfad0330f8856673050a2705ce.1690512863.git.takev@disroot.org
State New
Headers show
Series [bug#64909] * gnu/packages/game-development.scm (godot) [arguments, inputs]: use system brotli | expand

Commit Message

TakeV July 28, 2023, 2:54 a.m. UTC
I noticed this todo could be resolved, since the merge was built and
deployed upstream. 

---
 gnu/packages/game-development.scm | 6 ++----
 1 file changed, 2 insertions(+), 4 deletions(-)


base-commit: 35c8d631d2bd63c64e863b5509f29fdcb7f856e6
diff mbox series

Patch

diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 127cbac127..84bbd68cce 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -2017,10 +2017,6 @@  (define-public godot
                               "assimp"
                               "astcenc"
                               "basis_universal"
-                              ;; TODO: Can unbundle once
-                              ;; <https://github.com/godotengine/godot/pull/79101>
-                              ;; is merged
-                              "brotli"
                               ;; Godot needs ca-certificates.crt, but that is
                               ;; not available in build environment
                               "certs"
@@ -2067,6 +2063,7 @@  (define-public godot
                         "use_volk=no"
                         ;; Avoid using many of the bundled libs.
                         ;; Note: These options can be found in the SConstruct file.
+                        "builtin_brotli=no"
                         "builtin_embree=no"
                         "builtin_enet=no"
                         "builtin_freetype=no"
@@ -2193,6 +2190,7 @@  (define-public godot
      (list pkg-config))
     (inputs
      (list alsa-lib
+           brotli
            dbus
            embree
            enet