diff mbox series

[bug#63889,v3] gnu: add ruy

Message ID cfb7a0b4356514ece5bc122aa59df4ae3de85564.1686032266.git.atai@atai.org
State New
Headers show
Series [bug#63889,v3] gnu: add ruy | expand

Commit Message

Andy Tai June 6, 2023, 6:18 a.m. UTC
* gnu/packages/maths.scm (ruy): New variable
---
 gnu/packages/maths.scm | 33 +++++++++++++++++++++++++++++++++
 1 file changed, 33 insertions(+)


base-commit: 8937898af9433c0b7a8d95a78c95e21576ae22e8
diff mbox series

Patch

diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 4e34124469..c6fabf1973 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -8501,3 +8501,36 @@  (define-public scilab
 optimization, and modeling, simulation of explicit and implicit dynamical
 systems and symbolic manipulations.")
     (license license:cecill)))                    ;CeCILL v2.1
+
+
+(define-public ruy
+  (let ((commit "caa244343de289f913c505100e6a463d46c174de")
+        (version "0")
+        (revision "1"))
+    (package
+      (name "ruy")
+      (version (git-version version revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/google/ruy")
+                      (commit commit)
+                      (recursive? #t)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "0z9q2czk9im88zp8d9spiyx3y9l86rgqj0q0xxqq7vfg9ncypay2"))))
+      (build-system cmake-build-system)
+      (arguments
+       (list #:configure-flags #~(list
+                                        ;; needs to make sure code is relocatable for
+                                        ;; use in tensorflow
+                                        "-DCMAKE_CXX_FLAGS=-fPIC ")))
+      (home-page "https://github.com/google/ruy")
+      (synopsis "Matrix multiplication library")
+      (description
+       "Ruy is a matrix multiplication library.  Its focus is to cover the matrix
+multiplication needs of neural network inference engines.  Its initial user has
+been TensorFlow Lite, where it is used by default on the ARM CPU architecture.")
+      (license license:asl2.0))))
+