diff mbox series

[bug#42180,v2,21/23] gnu: Add erlang-rebar3-git-vsn.

Message ID cfa1dbc5baa06d5c3a76a28e5be935f55e832aa2.1633533541.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series [bug#42180,v2,01/23] guix: Add extracting-download. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel Oct. 6, 2021, 3:20 p.m. UTC
* gnu/packages/erlang.scm (erlang-rebar3-git-vsn): New variable.
---
 gnu/packages/erlang.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)

Comments

M Oct. 6, 2021, 6:43 p.m. UTC | #1
Hartmut Goebel schreef op wo 06-10-2021 om 17:20 [+0200]:
> * gnu/packages/erlang.scm (erlang-rebar3-git-vsn): New variable.
> ---
>  gnu/packages/erlang.scm | 30 ++++++++++++++++++++++++++++++
>  1 file changed, 30 insertions(+)
> 
> diff --git a/gnu/packages/erlang.scm b/gnu/packages/erlang.scm
> index 6003bec251..0e8a277970 100644
> --- a/gnu/packages/erlang.scm
> +++ b/gnu/packages/erlang.scm
> @@ -38,6 +38,7 @@
>    #:use-module (gnu packages gl)
>    #:use-module (gnu packages ncurses)
>    #:use-module (gnu packages perl)
> +  #:use-module (gnu packages version-control)
>    #:use-module (gnu packages tls)
>    #:use-module (gnu packages wxwidgets))
>  
> @@ -511,6 +512,35 @@ testing of stateful systems.")
>      (description "This package provides an Erlang providers library.")
>      (license license:asl2.0)))
>  
> +(define-public erlang-rebar3-git-vsn
> +  (package
> +    (name "erlang-rebar3-git-vsn")
> +    (version "1.1.1")
> +    (source
> +      (origin
> +        (method hexpm-fetch)
> +        (uri (hexpm-uri "rebar3_git_vsn" version))
> +        (sha256
> +          (base32 "1ra4xjyc40r97aqb8aq2rll1v8wkf9jyisnbk34xdqcgv9s9iw7d"))))
> +    (build-system rebar3-build-system)
> +    (inputs
> +     `(("git" ,git)))
> +    (arguments
> +     `(#:tests? #f ;; depends on rebar TODO: remove this dependency

I think you meant: ‘TODO: add this dependency here’.
I notice there's a ‘rebar’ package, which is also an implicit
input of rebar5-build-system, so maybe this ‘TODO: ’ has already been
resolved, and #:tests? can be set to #true?

Likewise for other packages.

Greetings,
Maxime
Hartmut Goebel Oct. 6, 2021, 9:09 p.m. UTC | #2
Am 06.10.21 um 20:43 schrieb Maxime Devos:
>> +     `(#:tests? #f ;; depends on rebar TODO: remove this dependency
> I think you meant: ‘TODO: add this dependency here’.
> I notice there's a ‘rebar’ package, which is also an implicit
> input of rebar5-build-system, so maybe this ‘TODO: ’ has already been
> resolved, and #:tests? can be set to #true?

Thanks for pointing on this. Now that rebar3 is packaged, this very 
package could of course use it. I tried to make it work:

      ;; Running the tests require binary artifact (tar-file containing
      ;; samples git repos)

So I need to keep the tests disabled, just for a different reason :-\
diff mbox series

Patch

diff --git a/gnu/packages/erlang.scm b/gnu/packages/erlang.scm
index 6003bec251..0e8a277970 100644
--- a/gnu/packages/erlang.scm
+++ b/gnu/packages/erlang.scm
@@ -38,6 +38,7 @@ 
   #:use-module (gnu packages gl)
   #:use-module (gnu packages ncurses)
   #:use-module (gnu packages perl)
+  #:use-module (gnu packages version-control)
   #:use-module (gnu packages tls)
   #:use-module (gnu packages wxwidgets))
 
@@ -511,6 +512,35 @@  testing of stateful systems.")
     (description "This package provides an Erlang providers library.")
     (license license:asl2.0)))
 
+(define-public erlang-rebar3-git-vsn
+  (package
+    (name "erlang-rebar3-git-vsn")
+    (version "1.1.1")
+    (source
+      (origin
+        (method hexpm-fetch)
+        (uri (hexpm-uri "rebar3_git_vsn" version))
+        (sha256
+          (base32 "1ra4xjyc40r97aqb8aq2rll1v8wkf9jyisnbk34xdqcgv9s9iw7d"))))
+    (build-system rebar3-build-system)
+    (inputs
+     `(("git" ,git)))
+    (arguments
+     `(#:tests? #f ;; depends on rebar TODO: remove this dependency
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'patch-path
+           (lambda* (#:key inputs #:allow-other-keys)
+             (let ((git (assoc-ref inputs "git")))
+               (substitute* "src/rebar3_git_vsn.erl"
+                 (("rebar_utils:sh\\(\"git " _)
+                  (string-append "rebar_utils:sh(\"" git "/bin/git ")))))))))
+    (home-page "https://github.com/soranoba/rebar3_git_vsn")
+    (synopsis "Rebar3 plugin for generating the version from git")
+    (description "This plugin adds support for generating the version from
+a git checkout.")
+    (license license:expat)))
+
 (define-public erlang-rebar3-raw-deps
   (package
     (name "erlang-rebar3-raw-deps")