diff mbox series

[bug#70252,v2,2/5] gnu: %opencl-sdk-version: Update to 2023.12.14.

Message ID cf8ce5b04c2faf9097683fc4acbf4fd0641909d9.1712521108.git.a.r.draidi@redscript.org
State New
Headers show
Series Update and restyle Khronos OpenCL packages | expand

Commit Message

Ahmad Draidi April 7, 2024, 8:33 p.m. UTC
This updates opencl-headers, opencl-clhpp and opencl-icd-loader.

* gnu/packages/opencl.scm (opencl-headers)[source]: Update hash.
[home-page]: Update URL.
(opencl-clhpp)[source]: Update hash.
(opencl-icd-loader)[source]: Update hash. Update origin URI to fix lint.

Change-Id: I674fc8aa79d1d98bac7ff66ba3a0e0fcb9b243cb
---
 gnu/packages/opencl.scm | 12 ++++++------
 1 file changed, 6 insertions(+), 6 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/opencl.scm b/gnu/packages/opencl.scm
index d6fb344458..b3d917d28b 100644
--- a/gnu/packages/opencl.scm
+++ b/gnu/packages/opencl.scm
@@ -53,7 +53,7 @@  (define-module (gnu packages opencl)
 ;; together (lockstep) and must be updated together. The following variable
 ;; facilitates that.
 
-(define %opencl-sdk-version "2023.02.06")
+(define %opencl-sdk-version "2023.12.14")
 
 (define-public opencl-headers
   (package
@@ -67,13 +67,13 @@  (define-public opencl-headers
               (commit (string-append "v" version))))
         (file-name (git-file-name name version))
         (sha256
-         (base32 "1jxpx15gwxc6i7vp64xlzcxf57nl0qnaiip6jyr0j7iji47dm404"))))
+         (base32 "13a5zv0nvjp66sswm6zdakmfjxp7536wplampbx9fa6q7i14lpy0"))))
     (build-system cmake-build-system)
     (arguments `(#:tests? #f)) ; Not enabled during build.
     (synopsis "The Khronos OpenCL headers")
     (description
      "This package provides the C headers by Khronos for OpenCL programming.")
-    (home-page "https://www.khronos.org/registry/OpenCL/")
+    (home-page "https://registry.khronos.org/OpenCL/")
     (license license:asl2.0)))
 
 (define (make-opencl-headers major-version subversion)
@@ -107,7 +107,7 @@  (define-public opencl-clhpp
              (url "https://github.com/KhronosGroup/OpenCL-CLHPP")
              (commit (string-append "v" version))))
        (sha256
-        (base32 "1m3v5apjv3qagym32xqg38pq6i8j5d8svz11clsx408nrlyngrj0"))
+        (base32 "0hagizc636wfcfmdl0f4bghprjnz1dba2kvkwh2ysj485n8lmjh4"))
        (file-name (git-file-name name version))))
     (native-inputs
      `(("python" ,python-wrapper)))
@@ -132,12 +132,12 @@  (define-public opencl-icd-loader
     (source (origin
               (method git-fetch)
               (uri (git-reference
-                    (url "https://github.com/KhronosGroup/OpenCL-ICD-Loader.git")
+                    (url "https://github.com/KhronosGroup/OpenCL-ICD-Loader")
                     (commit (string-append "v" version))))
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "1cmbcm6bz6kfvr0dy9hzf2vgfwcz8gbm8rxspqqpva6z74dz0qxr"))))
+                "03xjkfb98paya5h18qsqdf3gqp063iblgbgahcfji9q91i0b327z"))))
     (build-system cmake-build-system)
     (arguments `(#:tests? #f)) ; Tests need stub loader setup.
     (native-search-paths