diff mbox series

[bug#73073,v2,5/8] gnu: farstream: Move common origin from phases to native-inputs.

Message ID cf1a4f504158eab92bf066ed83cb0953baa4c62a.1725930587.git.zimon.toutoune@gmail.com
State New
Headers show
Series Allow origin inside inputs with "new style". | expand

Commit Message

Simon Tournier Sept. 10, 2024, 1:27 a.m. UTC
* gnu/packages/dlang.scm (farstream)[arguments]<phases>: Move common
origin from here...
[native-inputs]: ...to here.

Change-Id: I0023bca2fc021b82875b1ec7329c7e37116df0b3
---
 gnu/packages/freedesktop.scm | 24 +++++++++++++-----------
 1 file changed, 13 insertions(+), 11 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index cb1d625d24..56bd54a27f 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -263,16 +263,8 @@  (define-public farstream
             (lambda _
               (delete-file "autogen.sh")
               (copy-recursively
-               #$(origin
-                   (method git-fetch)
-                   (uri
-                    (git-reference
-                     (url "https://gitlab.freedesktop.org/gstreamer/common.git")
-                     (commit "52adcdb89a9eb527df38c569539d95c1c7aeda6e")))
-                   (file-name (git-file-name "common" "latest.52adcdb"))
-                   (sha256
-                    (base32
-                     "1zlm1q1lgcb76gi82rial5bwy2j9sz1x6x48ijhiz89cml7xxd1r")))
+               #$(this-package-native-input
+                  (git-file-name "common" "latest.52adcdb"))
                "common")))
           (add-after 'unpack 'disable-problematic-tests
             (lambda _
@@ -296,7 +288,17 @@  (define-public farstream
            libxslt
            perl
            pkg-config
-           python-wrapper))
+           python-wrapper
+           (origin
+             (method git-fetch)
+             (uri
+              (git-reference
+               (url "https://gitlab.freedesktop.org/gstreamer/common.git")
+               (commit "52adcdb89a9eb527df38c569539d95c1c7aeda6e")))
+             (file-name (git-file-name "common" "latest.52adcdb"))
+             (sha256
+              (base32
+               "1zlm1q1lgcb76gi82rial5bwy2j9sz1x6x48ijhiz89cml7xxd1r")))))
     (inputs
      (list glib
            gtk+