diff mbox series

[bug#56729,RFC,v3,19/32] gnu: pari-gp: Install galdata.

Message ID cee4ad028bca8d0df5878c8b4820c5be2dc61948.1685391447.git.guix@ikherbers.com
State New
Headers show
Series None | expand

Commit Message

vicvbcun May 29, 2023, 8:38 p.m. UTC
* gnu/packages/algebra.scm (pari-galdata): New variable.
(pari-gp)[arguments]<#:phases>: Add phase "install-galdata".
---

Notes:
    PARI/GP supports only a single load path.
    Multiple packages should work in a profile, as they get symlinked in a single folder.

 gnu/packages/algebra.scm | 16 +++++++++++++++-
 1 file changed, 15 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index 0b238d6f4b..c2d1c3ce1e 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -257,6 +257,16 @@  (define-public python-fpylll
     (description "fpylll is a Python wrapper for fplll.")
     (license license:gpl2+)))
 
+(define pari-galdata
+  ;; version from 2008-04-12
+  (origin
+    (method url-fetch)
+    ;; no versioning, old files seem to be moved to `old/...' on update
+    (uri "https://pari.math.u-bordeaux.fr/pub/pari/packages/galdata.tgz")
+    (sha256
+     (base32
+      "1pch6bk76f1i6cwwgm7hhxi5h71m52lqayp4mnyj0jmjk406bhdp"))))
+
 (define-public pari-gp
   (package
     (name "pari-gp")
@@ -282,7 +292,11 @@  (define-public pari-gp
                  (lambda _
                    (invoke "./Configure"
                            "--mt=pthread"
-                           (string-append "--prefix=" #$output)))))))
+                           (string-append "--prefix=" #$output))))
+               (add-after 'install 'install-galdata
+                 (lambda _
+                   (invoke "tar" "-xvf" #$pari-galdata)
+                   (copy-recursively "data/" (string-append #$output "/share/pari")))))))
     (synopsis "PARI/GP, a computer algebra system for number theory")
     (description
      "PARI/GP is a widely used computer algebra system designed for fast