diff mbox series

[bug#69435] gnu: c2ffi: Update to 16.0.0.0.

Message ID ced54e916b696c412690dab7ad70ba727a2260ac.1709061575.git.attila@lendvai.name
State New
Headers show
Series [bug#69435] gnu: c2ffi: Update to 16.0.0.0. | expand

Commit Message

Attila Lendvai Feb. 27, 2024, 7:19 p.m. UTC
From: Attila Lendvai <attila@lendvai.name>

Change-Id: I8b9562ea865347eafd2e098c3cf2b42611140aff
---
 gnu/packages/cpp.scm | 12 +++++++-----
 1 file changed, 7 insertions(+), 5 deletions(-)


base-commit: bf17a01e06abc100651ed643f2d5c7fea07d37ba

Comments

Guillaume Le Vaillant March 1, 2024, 2:07 p.m. UTC | #1
Patch applied as 9038a46751c5090246e64b63ff752064833c435b.
Thanks.
diff mbox series

Patch

diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index e530d1d2a89..2eacd795597 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -279,16 +279,18 @@  (define-public c2ffi
     (name "c2ffi")
     ;; As per the c2ffi README: the first three elements are encoding the
     ;; required Clang/LLVM version, and the last one is the c2ffi revision.
-    (version "12.0.0.0")
+    (version "16.0.0.0")
     (source
      (origin
        (method git-fetch)
        (uri (git-reference
              (url "https://github.com/rpav/c2ffi")
-             (commit (string-append "v" version))))
+             ;; Upstream is not tagging releases consistently.
+             ;; (commit (string-append "v" version))
+             (commit "097cbe61ca02dc79ea60859aa056975131a9d985")))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "1qq8dfismd20d9kfxpfvwz07v9mfvd0y7p5r3c92mk2pm4xnmzfy"))
+        (base32 "1mqhw4838chl495gaj9z0731ahkmqb4f3wlc1qalk82fdsaniyd5"))
        (modules '((guix build utils)))
        (snippet
         '(substitute* "CMakeLists.txt"
@@ -309,9 +311,9 @@  (define-public c2ffi
              (when tests?
                (invoke "./bin/c2ffi" "--help")))))))
     (native-inputs
-     (list clang-12)) ; CMakeLists.txt invokes `clang -print-resource-dir`
+     (list clang-16)) ; CMakeLists.txt invokes `clang -print-resource-dir`
     (inputs
-     (list clang-12)) ; Compiled with gcc, but links against libclang-cpp.so
+     (list clang-16)) ; Compiled with gcc, but links against libclang-cpp.so
     (home-page "https://github.com/rpav/c2ffi")
     (synopsis "Clang-based FFI wrapper generator")
     (description