diff mbox series

[bug#64258,v2,2/2] gnu: Add python-pgmpy.

Message ID cea70a863e005a929c2de729b459bc3b186ebb83.1699112426.git.felgru@posteo.net
State New
Headers show
Series Add pgmpy library for Bayesian Networks. | expand

Commit Message

Felix Gruber Nov. 4, 2023, 3:43 p.m. UTC
* gnu/packages/statistics.scm (python-pgmpy): New variable.

Change-Id: Ic9a42b534500cd1ed98869b8ac4bd3700ee3e2f6
---
 gnu/packages/statistics.scm | 43 +++++++++++++++++++++++++++++++++++++
 1 file changed, 43 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index d15732c839..d783464299 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -18,6 +18,7 @@ 
 ;;; Copyright © 2021 Frank Pursel <frank.pursel@gmail.com>
 ;;; Copyright © 2022 Simon Tournier <zimon.toutoune@gmail.com>
 ;;; Copyright © 2023 gemmaro <gemmaro.dev@gmail.com>
+;;; Copyright © 2023 Felix Gruber <felgru@posteo.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -7803,3 +7804,45 @@  (define-public ruby-enumerable-statistics
 statistical summary in arrays and enumerables.")
     (home-page "https://github.com/mrkn/enumerable-statistics")
     (license license:expat)))
+
+(define-public python-pgmpy
+  (package
+    (name "python-pgmpy")
+    (version "0.1.24")
+    (source
+     (origin
+       (method git-fetch)  ;pypi package does not include test data
+       (uri (git-reference
+             (url "https://github.com/pgmpy/pgmpy")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "0fvzh6v0yhgdryczamvzhfy2ymywkh0ssx4rl47xnfvi43hnij90"))))
+    (build-system pyproject-build-system)
+    (propagated-inputs (list python-daft
+                             python-joblib
+                             python-networkx
+                             python-numpy
+                             python-opt-einsum
+                             python-pandas
+                             python-pyparsing
+                             python-pytorch
+                             python-scikit-learn
+                             python-scipy
+                             python-statsmodels
+                             python-tqdm))
+    (native-inputs (list python-black
+                         python-codecov
+                         python-coverage
+                         python-mock
+                         python-pytest
+                         python-pytest-cov
+                         python-xdoctest))
+    (home-page "https://github.com/pgmpy/pgmpy")
+    (synopsis "Probabilistic Graphical Models library")
+    (description "This package provides a library for Probabilistic
+Graphical Models. It can be used for learning (Structure and Parameter),
+inference (Probabilistic and Causal), and simulations in Bayesian
+Networks.")
+    (license license:expat)))