diff mbox series

[bug#67798] gnu: Add python-find_libpython.

Message ID ce7eb3d9c60b7f7db03440d2206695d2548b2f12.1702398881.git.csantosb@inventati.org
State New
Headers show
Series [bug#67798] gnu: Add python-find_libpython. | expand

Commit Message

Cayetano Santos Dec. 12, 2023, 4:34 p.m. UTC
* gnu/packages/python-xyz.scm (python-find_libpython): New variable.

Signed-off-by: Cayetano Santos <csantosb@inventati.org>
---
 gnu/packages/python-xyz.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)


base-commit: 17b407ccb673020bfd923e0b5814574f9567383d

Comments

Cayetano Santos March 29, 2024, 9:06 a.m. UTC | #1
Submitted a new patch #70067
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 86f8d81689..2eecb7c55b 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -19672,6 +19672,28 @@  (define-public python-libcst-minimal
      (arguments '(#:tests? #f))
      (native-inputs '()))))
 
+(define-public python-find_libpython
+  (package
+    (name "python-find_libpython")
+    (version "0.3.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/ktbarrett/find_libpython")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "1d7y9srf5j8g34azf0j1jnnrn5al55cnzb4kkx2l1q8hys0l040c"))))
+    (build-system python-build-system)
+    (home-page "https://github.com/ktbarrett/find_libpython")
+    (synopsis
+     "Locate libpython associated with this Python executable")
+    (description
+     "The library is designed to find the path to the libpython dynamic library for the current Python environment.")
+    (license license:expat)))
+
 (define-public python-typing-inspect
   (package
     (name "python-typing-inspect")