diff mbox series

[bug#69251] gnu: Add r-abbreviate.

Message ID ce6d33884c81110d3fe99ece4d3d32c443248875.1708281031.git.wz@freeshell.de
State New
Headers show
Series [bug#69251] gnu: Add r-abbreviate. | expand

Commit Message

Wiktor Żelazny Feb. 18, 2024, 6:31 p.m. UTC
* gnu/packages/cran.scm (r-abbreviate): New variable.
---
 gnu/packages/cran.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)


base-commit: fdbf4192f5eaa7fdb5e6e2e98ada0726c8104824

Comments

Skyler Ferris Feb. 18, 2024, 11:05 p.m. UTC | #1
Hi Wiktor,

Thanks for submitting this patch! I'm adding some review notes to this 
thread in hopes that whichever committer looks at this patch will be 
able to process it more efficiently. It looks clean to me overall. I did 
mark "Project is maintained" as "Attention" more as an indication to the 
committer than to you. I think this is fine but it seems abnormal to me, 
although I am new to reviewing patches so maybe it is more normal than I 
think. =) If you have any additional context to add I am sure it will be 
appreciated! I will send detailed notes about this and everything else I 
looked at in a separate email. I welcome any feedback you have about my 
review process.

Regards,
Skyler
Skyler Ferris Feb. 18, 2024, 11:06 p.m. UTC | #2
Each section includes a checklist based on (and expands upon) the items 
listed in the manual (22.7 "Submitting Patches"). Each checklist item 
may have one of the following statuses:

C: Commitable. This item looks as expected for a final commit.
CC: Commitable with Context. Like commitable, but some notes have been 
added providing context about anything notable or unusual. These notes 
are provided for transparency and should not be interpreted as meaning 
that I object to the patch.
MR: Minor Repair. There is something about the patch which I think 
should ideally be changed, but I do not think that the patch should be 
refused on this basis alone.
A: Attention. Something in the patch needs attention from the author, 
the committer, or both. Resolving the matter may or may not require a 
change to the patch.
XX: This item is not relevant to the patch.
Blank: I did not review this aspect of the patch.

[C ] Applies cleanly (commit fdbf4192f5eaa7fdb5e6e2e98ada0726c8104824)
[C ] Commit message looks correct & complete
[CC] Cryptographic hash
[A ] Project is maintained
[C ] Synopsis & Description
[C ] Package license matches source license
[C ] No compiler warnings (guix project, not package build)
[CC] `guix lint` output
[C ] `guix style` output
[C ] Package builds (my host is an x86_64 Xen guest)
[  ] Builds for other architectures
[C ] No bundled software
[CC] Works in container with minimal inputs
[C ] `guix size` output
[XX] Dependent packages (`guix refresh --list-dependent PACKAGE`)
[C ] `guix build --rounds=2`
[C ] Gender-neutral wording
[C ] One set of related changes
[CC] Simulated guix pull

# Cryptographic Hash

I was not able to locate a cryptographic hash for this package.

# Project is Maintained

All of the commits are from the end of 2021 and the version remains at 
"0.1". However, the package is doing something relatively simple and 
there are no open issues on the GitHub page (to be fair, there is only 
one closed issue and it was handled ~2 months after the project was 
uploaded).

There were about 1000 downloads within the past month at time of writing 
(https://cranlogs.r-pkg.org/badges/last-month/abbreviate), implying that 
some number of people are using the package. Combined with the lack of 
issue reports, this gives some confidence that the lack of new commits 
is "this doesn't need any changes" rather than "this is unmaintained".

# guix lint

There is a note that the source is not archived on Software Heritage or 
Disarchive database. The 'archival' section in the "Invoking 'guix 
lint'" chapter (9.8) indicates that the Software Heritage will pick up 
the source at some point in the future.

# Works in container with minimal inputs

I used the following environment:

$ ./pre-inst-env guix shell -C r-abbreviate r
 > library(abbreviate)

Then I entered some of the example commands from the README. The calls 
were successful and produced reasonable-looking output.

# Simulated Guix Pull

I committed the diff locally and used `--disable-authentication`, which 
I think is fine because the signature on the commit is unrelated to the 
contents of the commit in this context.
Ricardo Wurmus Feb. 19, 2024, 12:57 p.m. UTC | #3
Wiktor Żelazny <wz@freeshell.de> writes:

> * gnu/packages/cran.scm (r-abbreviate): New variable.

Applied, thank you!

Skyler: Thanks for the review!
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index bcb5ab4964..2a5de1d907 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -116,6 +116,26 @@  (define-module (gnu packages cran)
   #:use-module (gnu packages xml)
   #:use-module (gnu packages xorg))
 
+(define-public r-abbreviate
+  (package
+    (name "r-abbreviate")
+    (version "0.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "abbreviate" version))
+       (sha256
+        (base32 "1cvjdbi17qz8gr5898zchm5fyz4n51z66lwps25v8a9mhwab8imi"))))
+    (properties `((upstream-name . "abbreviate")))
+    (build-system r-build-system)
+    (home-page "https://github.com/sigbertklinke/abbreviate")
+    (synopsis "Readable string abbreviation")
+    (description
+     "This package abbreviates strings to a specified minimum number of characters,
+such that the strings remain unique (if they originally were).")
+    ;; The license is mentioned in the DESCRIPTION file.
+    (license license:gpl3)))
+
 (define-public r-aer
   (package
     (name "r-aer")