diff mbox series

[bug#72578] gnu: Add fooyin.

Message ID ce3335e5354c19829444fa46e6a29adca58fc777.1723387985.git.rodion.goritskov@gmail.com
State New
Headers show
Series [bug#72578] gnu: Add fooyin. | expand

Commit Message

Rodion Goritskov Aug. 11, 2024, 2:53 p.m. UTC
* gnu/packages/music.scm (fooyin): New variable.

Change-Id: I8bf9021041acc1a063da243c0a9e592d066fb5f7
---
 gnu/packages/music.scm | 37 +++++++++++++++++++++++++++++++++++++
 1 file changed, 37 insertions(+)


base-commit: 174ecf5b1077d29498d9de22e27b13047f314feb
prerequisite-patch-id: a6d84a59be284d4ee6b31487379b377c569986ac

Comments

Steve George Oct. 31, 2024, 11:19 a.m. UTC | #1
Hi,

Thanks for sending the patch to add Fooyin music player to Guix. 

I just had a quick look and you turned off tests, but I can see tests in the Git repository. Did you try to get them running and they failed, or was there some other reason for not running them? We generally prefer to have tests if at all possible.

Thanks,

Futurile
diff mbox series

Patch

diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 100a41f87b..a8e1e90b30 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -656,6 +656,43 @@  (define-public ctrlr
                      license:gpl3       ;JUCE
                      license:bsd-3)))))
 
+(define-public fooyin
+  (package
+    (name "fooyin")
+    (version "0.5.3")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/fooyin/fooyin")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0sy0l65440a23fazvw27wcjjsiylmqb2zpvnx82d6hyj60xsgjw7"))))
+    (build-system cmake-build-system)
+    (arguments
+     `(#:tests? #f))
+    (native-inputs (list pkg-config))
+    (inputs (list alsa-lib
+                  ffmpeg
+                  icu4c
+                  kdsingleapplication
+                  pipewire
+                  qtbase
+                  qttools
+                  qtsvg
+                  sdl2
+                  taglib
+                  zlib))
+    (home-page "https://github.com/fooyin/fooyin")
+    (description
+     "Fooyin is a music player built around customisation.
+It offers a growing list of widgets to manage and play your local music collection.
+It's extensible using a plugin system and many widgets make use of FooScript
+to offer an even deeper level of control.")
+    (synopsis "Customisable Qt-based music player")
+    (license license:gpl3)))
+
 (define-public qmmp
   (package
     (name "qmmp")