diff mbox series

[bug#37886] gnu: Add ipcalc.

Message ID ce191ac2-4a64-65c9-5085-836322082b78@danielschaefer.me
State Accepted
Headers show
Series [bug#37886] gnu: Add ipcalc. | expand

Commit Message

Daniel Schäfer Dec. 1, 2019, 4:32 p.m. UTC
Hello Ludo and Matthieu,

thanks for taking a look. Sorry, I did not receive Matthieu's answer and I'm not subscribed to the patches ML.

It seems that etc/indent-code.el does not correct that particular formatting difference, which I had in my description attribute.
I corrected it manually, according to what the other packages look like.
It's also moved into networking.scm.

off-topic @Ludo, What's the language of your MUA? Ido? (https://en.wiktionary.org/wiki/skribis)

--8<---------------cut here---------------start------------->8---
From b511c6a206cb61c22f3da3d6682bfc2a37035463 Mon Sep 17 00:00:00 2001
From: Daniel Schaefer <git@danielschaefer.me>
Date: Wed, 23 Oct 2019 15:29:48 +0200
Subject: [PATCH] gnu: Add ipcalc.

* gnu/packages/networking.scm (ipcalc): New variable.
---
 gnu/packages/networking.scm | 54 +++++++++++++++++++++++++++++++++++++
 1 file changed, 54 insertions(+)

Comments

Mathieu Othacehe Dec. 2, 2019, 8:10 a.m. UTC | #1
Hello Daniel,

> It seems that etc/indent-code.el does not correct that particular formatting difference, which I had in my description attribute.
> I corrected it manually, according to what the other packages look like.
> It's also moved into networking.scm.

I simplified the builder procedure and removed an explicit reference to
package version. I also fixed the license field and the description.

Anyway, pushed, thanks for your patch :)

Mathieu
diff mbox series

Patch

diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 1b31314485..13728038d8 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -34,6 +34,7 @@ 
 ;;; Copyright © 2019 Tonton <tonton@riseup.net>
 ;;; Copyright © 2019 Alex Griffin <a@ajgrf.com>
 ;;; Copyright © 2019 Jan Wielkiewicz <tona_kosmicznego_smiecia@interia.pl>
+;;; Copyright © 2019 Daniel Schaefer <git@danielschaefer.me>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -61,6 +62,7 @@ 
   #:use-module (guix build-system go)
   #:use-module (guix build-system perl)
   #:use-module (guix build-system python)
+  #:use-module (guix build-system trivial)
   #:use-module (gnu packages)
   #:use-module (gnu packages admin)
   #:use-module (gnu packages adns)
@@ -2778,3 +2780,55 @@  a service (such as an HTTP or SSH server) on localhost visible to the wider
 Internet, even behind NAT or restrictive firewalls.  A managed front-end relay
 service is available at @url{https://pagekite.net/}, or you can run your own.")
     (license license:agpl3+)))
+
+(define-public ipcalc
+  (package
+    (name "ipcalc")
+    (version "0.41")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "http://jodies.de/ipcalc-archive/"
+                                  name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "12if9sm8h2ac0pgwkw835cgyqjxm6h27k4kfn2vfas9krrqwbafx"))))
+    (inputs `(("perl" ,perl)
+              ("tar" ,tar)
+              ("gzip" ,gzip)
+              ("tarball" ,source)))
+    (build-system trivial-build-system) ; no Makefile.PL
+    (arguments
+     '(#:modules ((guix build utils))
+                 #:builder (begin
+                             (use-modules (guix build utils))
+                             (use-modules (srfi srfi-1))
+                             (let* ((tarball    (assoc-ref %build-inputs "tarball"))
+                                    (perl       (string-append (assoc-ref %build-inputs
+                                                                          "perl")
+                                                               "/bin"))
+                                    (gzip       (string-append (assoc-ref %build-inputs
+                                                                          "gzip")
+                                                               "/bin/gzip"))
+                                    (tar        (string-append (assoc-ref %build-inputs
+                                                                          "tar")
+                                                               "/bin/tar"))
+                                    (out        (assoc-ref %outputs "out"))
+                                    (bin        (string-append out "/bin"))
+                                    (doc        (string-append out "/share/doc/ipcalc")))
+                               (copy-file tarball "ipcalc.tar.gz")
+                               (invoke gzip "-d" "ipcalc.tar.gz")
+                               (invoke tar "xvf" "ipcalc.tar")
+
+                               (mkdir-p bin)
+                               (install-file "ipcalc-0.41/ipcalc" bin)
+                               (patch-shebang (string-append bin "/ipcalc") (list perl))
+                               (install-file "ipcalc-0.41/ipcalc" doc)
+                               #t))))
+    (synopsis "Simple IP network calculator")
+    (description "ipcalc takes an IP address and netmask and calculates the
+resulting broadcast, network, Cisco wildcard mask, and host range. By giving a
+second netmask, you can design subnets and supernets. It is also intended to be
+a teaching tool and presents the subnetting results as easy-to-understand
+binary values.")
+    (home-page "http://jodies.de/ipcalc")
+    (license gpl2+)))