diff mbox series

[bug#66528,2/2] gnu: Add r-tgstat.

Message ID ce1510783f18dce8ca481e5be582d1e3b75bb708.1697212635.git.Navid.Afkhami@mdc-berlin.de
State New
Headers show
Series [bug#66527,1/2] gnu: Remove r-tgstat. | expand

Commit Message

nafkhamdc Oct. 13, 2023, 3:57 p.m. UTC
* gnu/packages/cran.scm (r-tgstat): New variable.
---
 gnu/packages/cran.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 1c37635ea5..de31f44dbd 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -3257,6 +3257,29 @@  (define-public r-tgp
 noisy black-box functions.")
     (license license:lgpl2.0+)))
 
+(define-public r-tgstat
+  (package
+    (name "r-tgstat")
+    (version "2.3.24")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "tgstat" version))
+       (sha256
+        (base32 "0czd3j7z30jgb03813s0jc0701ypnwpkkq7var6n6f6cj7sdvc0l"))))
+    (properties `((upstream-name . "tgstat")))
+    (build-system r-build-system)
+    (native-inputs (list r-knitr))
+    (home-page "https://cran.r-project.org/package=tgstat")
+    (synopsis "Amos Tanay's Group High Performance Statistical Utilities")
+    (description
+     "This package provides a collection of high-performance utilities.
+It can be used to compute distances, correlations, autocorrelations,
+clustering, and other tasks.  It also contains a graph clustering
+algorithm described in MetaCell analysis of single-cell RNA-seq
+data using K-nn graph partitions.")
+    (license license:gpl2)))
+
 (define-public r-tidyft
   (package
     (name "r-tidyft")