diff mbox series

[bug#68639] gnu: patool: Update to 2.1.0.

Message ID cdd923cf64353a91a311e8e46795f9c9e50405e5.1705854257.git.felgru@posteo.net
State New
Headers show
Series [bug#68639] gnu: patool: Update to 2.1.0. | expand

Commit Message

Felix Gruber Jan. 21, 2024, 4:24 p.m. UTC
* gnu/packages/patool.scm (patool): Update to 2.1.0.
  [build-system]: Change to pyproject-build-system.
  [arguments]: Remove custom 'check phase and disable failing tests.

Change-Id: Ic4f1baadc1122d6f67f0b3faa9cb2d709e19e481
---
 gnu/packages/patool.scm | 21 ++++++++++++---------
 1 file changed, 12 insertions(+), 9 deletions(-)


base-commit: 121de47decc1029c06f6e46e5f06d7fefe8e85ec

Comments

Sharlatan Hellseher Feb. 10, 2024, 9:19 a.m. UTC | #1
Hi,

I've not noticed this patch while fixing the build.
It was updated in c439bb2683..6dcc097cd8.

Closing as completed already.

Thanks,
Oleg
diff mbox series

Patch

diff --git a/gnu/packages/patool.scm b/gnu/packages/patool.scm
index 31dfd994b1..788298f29e 100644
--- a/gnu/packages/patool.scm
+++ b/gnu/packages/patool.scm
@@ -1,5 +1,6 @@ 
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2024 Felix Gruber <felgru@posteo.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -20,7 +21,7 @@  (define-module (gnu packages patool)
   #:use-module ((guix licenses) #:prefix license:)
   #:use-module (guix git-download)
   #:use-module (guix packages)
-  #:use-module (guix build-system python)
+  #:use-module (guix build-system pyproject)
   #:use-module (gnu packages)
   #:use-module (gnu packages backup)
   #:use-module (gnu packages cdrom)
@@ -35,7 +36,7 @@  (define-module (gnu packages patool)
 (define-public patool
   (package
     (name "patool")
-    (version "1.12")
+    (version "2.1.0")
     (source
      (origin
        (method git-fetch)               ;no test data in PyPI archive
@@ -45,14 +46,16 @@  (define-public patool
        (file-name (git-file-name name version))
        (sha256
         (base32
-         "0zgvgx9549rvb57rgkpjalydz46k71gibfs6ab3b3sy439s0ay4h"))))
-    (build-system python-build-system)
+         "1nbn3wbcbng17jf18sx7aks8mkyvy08w32xwvczqmw91pn5r0vpw"))))
+    (build-system pyproject-build-system)
     (arguments
-     `(#:phases (modify-phases %standard-phases
-                  (replace 'check
-                    (lambda* (#:key tests? #:allow-other-keys)
-                      (when tests?
-                        (invoke "pytest")))))))
+     (list
+      #:test-flags
+      ;disable failing tests
+      '(list (string-append "-k (not test_mime_file_gzip"
+                            " and not test_bsdtar_gz_file"
+                            " and not test_py_tarfile_gz_file"
+                            " and not test_tar_gz_file)"))))
     (native-inputs
      (list bzip2
            cabextract