diff mbox series

[bug#38097] Add gnome-xyz for themes and shell extensions

Message ID cd688e97d61e1afd2cc281cd70cda9bee9309901.camel@student.tugraz.at
State Accepted
Headers show
Series [bug#38097] Add gnome-xyz for themes and shell extensions | expand

Commit Message

Leo Prikler Nov. 7, 2019, 6:34 p.m. UTC
> Overall this looks fine, thanks. The indentation of the first patch
> is
> wrong. Also you have several lines hitting the 78 columns limit. You
> need to wrap them manually.
Forgetting to hit TAB, my old nemesis.  I assume this limit counts for
ChangeLog entries too, does it?

> Can you please send an updated version?
Of course.  I've reformatted all three of them and added them again
here as attachments.  I also ran `guix lint` this time with the
formatting checks enabled, as I should have before sending the first
one :)

Regards,

Leo

Comments

Mathieu Othacehe Nov. 8, 2019, 9:36 p.m. UTC | #1
Hello,

> Forgetting to hit TAB, my old nemesis.  I assume this limit counts for
> ChangeLog entries too, does it?

Yes it counts, but using magit your lines are automatically wrapped :)

>> Can you please send an updated version?
> Of course.  I've reformatted all three of them and added them again
> here as attachments.  I also ran `guix lint` this time with the
> formatting checks enabled, as I should have before sending the first
> one :)

I edited the commit titles a bit before pushing.

Thanks,

Mathieu
diff mbox series

Patch

From 0b3f6bde7b70f3b098421a16877fe0879977a23c Mon Sep 17 00:00:00 2001
From: Leo Prikler <leo.prikler@student.tugraz.at>
Date: Thu, 7 Nov 2019 10:22:02 +0100
Subject: [PATCH 3/3] gnu: add gnome-shell-extension-noannoyance

* gnu/packages/gnome-xyz: (gnome-shell-extension-noannoyance): New variable.
---
 gnu/packages/gnome-xyz.scm | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)

diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index 106226bf2f..d6da1e4bbb 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -95,3 +95,34 @@  transforming it into a dock for easier application launching and faster window
 switching.")
     (home-page "https://micheleg.github.io/dash-to-dock/")
     (license license:gpl2+)))
+
+(define-public gnome-shell-extension-noannoyance
+  (package
+    (name "gnome-shell-extension-noannoyance")
+    (version "5")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/BjoernDaase/noannoyance.git")
+                    (commit "e37b5b3c31f577b4698bc6659bc9fec5ea9ac5d4")))
+              (sha256
+               (base32
+                "0fa8l3xlh8kbq07y4385wpb908zm6x53z81q16xlmin97dln32hh"))
+              (file-name (git-file-name name version))))
+    (build-system trivial-build-system)
+    (arguments
+     '(#:modules ((guix build utils))
+       #:builder
+       (begin
+         (use-modules (guix build utils))
+         (let ((dst (string-append
+                     (assoc-ref %outputs "out")
+                     "/share/gnome-shell/extensions/"
+                     "noannoyance@daase.net")))
+           (mkdir-p dst)
+           (copy-recursively (assoc-ref %build-inputs "source") dst)))))
+    (synopsis "Removes 'Window is ready' annotation")
+    (description "One of the many extensions, that remove this message.
+It uses ES6 syntax and claims to be more actively maintained than others.")
+    (home-page "https://extensions.gnome.org/extension/2182/noannoyance/")
+    (license license:gpl2)))
-- 
2.24.0