diff mbox series

[bug#60029,2/4] gnu: vim: add relevant locations to 'package-path' instead of 'runtime-path'

Message ID cd1a382fd5034e697bca86428cfd2d07dc11b76f.1670891520.git.me@jonscoresby.com
State New
Headers show
Series vim-build-system | expand

Commit Message

Jonathan Scoresby Dec. 13, 2022, 8:34 a.m. UTC
---
 gnu/packages/aux-files/guix.vim | 10 ++--------
 1 file changed, 2 insertions(+), 8 deletions(-)

Comments

\( Dec. 13, 2022, 7:06 p.m. UTC | #1
Could you please add a note to the second commit explaining why exactly
it's needed?

    -- (
Jonathan Scoresby Dec. 13, 2022, 10:10 p.m. UTC | #2
> On 12/13/2022 12:06 MST ( <paren@disroot.org> wrote:
> 
> > Wow, this is really nice work! :D

Thanks!

> Could you please add a note to the second commit explaining why exactly
> it's needed?

Sorry, do you mean to the commit message or to the file itself? 

Thank you for the review.
\( Dec. 14, 2022, 6:56 a.m. UTC | #3
On Tue Dec 13, 2022 at 10:10 PM GMT, Jonathan Scoresby wrote:
> Sorry, do you mean to the commit message or to the file itself? 

To the commit message, please.

    -- (
diff mbox series

Patch

diff --git a/gnu/packages/aux-files/guix.vim b/gnu/packages/aux-files/guix.vim
index 9397c53701..7e7f8d653a 100644
--- a/gnu/packages/aux-files/guix.vim
+++ b/gnu/packages/aux-files/guix.vim
@@ -1,13 +1,7 @@ 
-" This appends all of the vim plugins to the end of Vim's runtimepath.
+" This apends all applicable vim paths to the end of packagepath
 for directory in ["/run/current-system/profile", $HOME . "/.guix-profile", $HOME ."/.guix-home/profile", $GUIX_PROFILE, $GUIX_ENVIRONMENT]
     let vimplugins = directory . "/share/vim/vimfiles"
     if isdirectory(vimplugins)
-        let &rtp = join([&rtp,vimplugins], ',')
+        let &pp = join([&pp,vimplugins], ',')
     endif
 endfor
-" Unconditionally add */after directories last, as intended by upstream
-" TODO: Remove duplicate */after directories
-for directory in [$VIM . "/vimfiles", $HOME ."/.vim"]
-    let vimplugins = directory . "/after"
-    let &rtp = join([&rtp,vimplugins], ',')
-endfor