diff mbox series

[bug#57429,2/3] gnu: piper: Unbreak tests.

Message ID ccdad1e3ba9d3441bc0eabdfabffab6fb76b9bb6.1661501683.git.tobias.kortkamp@gmail.com
State Accepted
Headers show
Series gnu: piper: Fix runtime and update to 0.7 | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Tobias Kortkamp Aug. 26, 2022, 2:37 p.m. UTC
Make flake8 config available inside the build directory.

https://github.com/libratbag/piper/pull/781

* gnu/packages/gnome.scm (piper): Unbreak tests.
---
 gnu/packages/gnome.scm | 7 +++++--
 1 file changed, 5 insertions(+), 2 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index fe822eb035..83d64fbd49 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -12123,7 +12123,6 @@  (define-public piper
            python-pygobject))
     (arguments
      (list #:glib-or-gtk? #t
-           #:tests? #f ;; The flake8 test fails trying to validate piper.in as code.
            #:phases
            #~(modify-phases %standard-phases
                (add-after 'unpack 'dont-update-gtk-icon-cache
@@ -12140,7 +12139,11 @@  (define-public piper
                      (wrap-program
                          (string-append #$output "/bin/piper")
                        `("GUIX_PYTHONPATH" = (,(getenv "GUIX_PYTHONPATH") ,pylib))
-                       `("GI_TYPELIB_PATH" = (,(getenv "GI_TYPELIB_PATH"))))))))))
+                       `("GI_TYPELIB_PATH" = (,(getenv "GI_TYPELIB_PATH")))))))
+               (add-before 'check 'flake8-config
+                 (lambda _
+                   ;; Make sure the tests use the local flake8 config
+                   (symlink (string-append #$source "/.flake8") ".flake8"))))))
     (home-page "https://github.com/libratbag/piper/")
     (synopsis "Configure bindings and LEDs on gaming mice")
     (description "Piper is a GTK+ application for configuring gaming mice with