[bug#76746,v2,02/13] gnu: python-rapidfuzz: Update to 3.10.1.
Commit Message
* gnu/packages/python-xyz.scm (python-rapidfuzz): Update to 3.10.1.
[native-inputs]: Add cmake-minimal, to not build pure-Python version.
Replace python-scikit-build with python-scikit-build-core.
Change-Id: I5a28bf883377814465ae088ae5fbde81120e03bb
---
gnu/packages/python-xyz.scm | 16 ++++++++++------
1 file changed, 10 insertions(+), 6 deletions(-)
@@ -2860,19 +2860,23 @@ (define-public python-d2to1
(define-public python-rapidfuzz
(package
(name "python-rapidfuzz")
- (version "3.6.1")
+ (version "3.10.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "rapidfuzz" version))
(sha256
- (base32 "1rrx043zqqql31pcp92k61digibymp3l382gaxr4h8717kp0nrim"))))
+ (base32 "0yarb1k40a36f4p2afy5was9ifbq1jdyyyfw88zmp4bshinm85as"))))
(build-system pyproject-build-system)
(native-inputs
- (list python-packaging
- python-pytest
- python-scikit-build
- python-setuptools))
+ (list
+ ;; If it doesn't detect cmake, it will build a pure-Python version that
+ ;; fails some tests.
+ cmake-minimal
+ python-packaging
+ python-pytest
+ python-scikit-build-core
+ python-setuptools))
(home-page "https://github.com/rapidfuzz/RapidFuzz")
(synopsis "Rapid fuzzy string matching")
(description "RapidFuzz is a fast string matching library for Python and