diff mbox series

[bug#44470] gnu: Added emacs-solidity.

Message ID ccb317a1-1fab-f9bf-0ab9-d283f87a0e0d@riseup.net
State Accepted
Headers show
Series [bug#44470] gnu: Added emacs-solidity. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Martin Becze Nov. 5, 2020, 7:50 p.m. UTC
Thank you for the review Nocolas. I choose the latest commit because it 
fixes some spacing issues and has support for more keywords. While not 
absolutely necessary the release cycle seems to be very slow and this is 
the version that is on Melpa. Attachedd is an updated patch.

On 11/5/20 11:07 AM, Nicolas Goaziou wrote:
> Hello,
> 
> Martin Becze <mjbecze@riseup.net> writes:
> 
>> * gnu/packages/emacs-xyz.scm (emacs-solidity): New variable.
> 
> Thank you.
> 
>> +  ;; No release.
>> +  (let ((commit "d166a86b83907e0cfd64c191e9dfce4b44a9843e"))
> 
> Is there any reason to use this particular instead of
> e91c36cc20a2e683b930712a7f9c0ab28451b347, which is the exact "0.1.10"
> release? If so, please mention it in the comment above.
> 
>> +    (package
>> +      (name "emacs-solidity")
>> +      (version (git-version "0.1.10" "1" commit))
> 
> If we use the commit above, `version' can simply become "0.1.10".
> 
>> +      (source
>> +       (origin
>> +         (method git-fetch)
>> +         (uri (git-reference
>> +               (url "https://github.com/ethereum/emacs-solidity")
>> +               (commit commit)))
>> +         (file-name (git-file-name name version))
>> +         (sha256
>> +          (base32 "19hgvsrqch2vp49ag6m76bi5qxd20v95z0ib838rib9as15b17wq"))))
>> +      (build-system emacs-build-system)
>> +      (propagated-inputs
>> +       `(("emacs-company" ,emacs-company)
>> +         ("emacs-flycheck" ,emacs-flycheck)))
>> +      (home-page "https://github.com/ethereum/emacs-solidity")
>> +      (synopsis "Major mode for writing Solidity code")
>> +      (description "A simple language mode for the Solidity language.  It is a
>> +constant work in progress as the language itself also progresses.")
> 
> The first sentence should be "complete", i.e., with a subject and
> a verb.
> 
> Could you send an updated patch?
> 
> Regards,
>
diff mbox series

Patch

From 1216fc95cc9b480375e8dc344510f1a24f7b2c84 Mon Sep 17 00:00:00 2001
From: Martin Becze <mjbecze@riseup.net>
Date: Thu, 5 Nov 2020 09:18:01 -0600
Subject: [PATCH v1] gnu: Added emacs-solidity.

* gnu/packages/emacs-xyz.scm (emacs-solidity): New variable.
---
 gnu/packages/emacs-xyz.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 2043ce19df..78cf2e31c3 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -25281,3 +25281,28 @@  the TypeScript implementation.")
       (description "This package provides an Emacs client for the Rocket.chat
 service.")
       (license license:expat))))
+
+(define-public emacs-solidity
+  ;; This commit fixes a spacing issue and adds new keywords
+  (let ((commit "d166a86b83907e0cfd64c191e9dfce4b44a9843e"))
+    (package
+      (name "emacs-solidity")
+      (version (git-version "0.1.10" "1" commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/ethereum/emacs-solidity")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "19hgvsrqch2vp49ag6m76bi5qxd20v95z0ib838rib9as15b17wq"))))
+      (build-system emacs-build-system)
+      (propagated-inputs
+       `(("emacs-company" ,emacs-company)
+         ("emacs-flycheck" ,emacs-flycheck)))
+      (home-page "https://github.com/ethereum/emacs-solidity")
+      (synopsis "Major mode for writing Solidity code")
+      (description "This is a simple language mode for the Solidity language.
+It is a constant work in progress as the language itself also progresses.")
+      (license license:gpl3+))))
-- 
2.29.2