diff mbox series

[bug#57923] gnu: Add sov.

Message ID cc5985eb40bec0b88790edee3d5702834bbc9f47.1663561961.git.kiasoc5@disroot.org
State New
Headers show
Series [bug#57923] gnu: Add sov. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

kiasoc5 Sept. 19, 2022, 4:32 a.m. UTC
* gnu/packages/wm.scm (sov): New variable.
---
 gnu/packages/wm.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)


base-commit: 25adb336bcb0188a92ecbe6b9c1d9d3e3a8b59e4

Comments

M Sept. 19, 2022, 4:35 p.m. UTC | #1
On 19-09-2022 06:32, kiasoc5 via Guix-patches via wrote:
> +   (inputs (list wayland))
> +   (native-inputs (list pkg-config freetype wayland-protocols))

I think 'freetype' and maybe 'wayland-protocols' might be sorted 
incorrectly -- 'freetype' is usually used at runtime (hence 'inputs', 
not 'native-inputs') and wayland-protocols is often used for its 
'wayland-scanner' (or maybe that was 'wayland'), hence 'native-inputs' 
(sometimes to resolve cross-compilation errors it needs to be both 
'native-inputs' and 'inputs').

To test, you can try to cross-compile:

./pre-inst-env guix build sov --target=aarch64-linux-gnu

and move inputs as needed to resolve compilation failures.

Also, it looks like it bundles a copy of jsmn, at
https://github.com/milgra/sov/blob/main/src/modules/json/jsmn.c
-- while unbundling is not required if it's the only copy in Guix, a ";; 
TODO bundles jsmn" would be useful to keep track of bundling.

(Actually there is another copy though, in 'acme-client', but strictly 
speaking '(guix)Submitting Patches' only talks about 'already available 
as separate packages', not 'there is another copy'.)

In src/sov/config/fontconfig.c, there is some code for starting 
"fc-match", which needs a 'substitute*' so fc-match will be found even 
if fontconfig is not in the current environment.

Greetings,
Maxime.
diff mbox series

Patch

diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index f329020eb4..d9fb57a7d2 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -2834,6 +2834,28 @@  (define-public avizo
 used for multimedia keys.")
     (license license:gpl3+)))
 
+(define-public sov 
+  (package
+   (name "sov")
+   (version "0.73")
+   (source (origin
+            (method url-fetch)
+	    (uri (string-append
+		  "https://github.com/milgra/sov/releases/download/"
+		  version "/sov-" version ".tar.xz"))
+            (sha256
+             (base32
+              "0mpqd7rg1d4qfkkwcyxr4p4acp07i938p3mjij7v45b8lac8sbg6"))))
+   (build-system meson-build-system)
+   (inputs (list wayland))
+   (native-inputs (list pkg-config freetype wayland-protocols))
+   (home-page "https://github.com/milgra/sov")
+   (synopsis "Sway Overview")
+   (description
+    "An overlay that shows schemas for all workspaces to make navigation
+in Sway easier")
+   (license license:expat)))
+
 (define-public grimshot
   (package
     (inherit sway)