[bug#76513,rust-team,36/77] gnu: Add rust-indexmap-nostd-0.4.

Message ID cc45a5e8b190576f44cca4a909db0dd0ee49899c.1740340805.git.wongandj@icloud.com
State New
Headers
Series Add module (gnu packages typst) and packages |

Commit Message

Andrew Wong Feb. 23, 2025, 8:21 p.m. UTC
  * gnu/packages/crates-io.scm (rust-indexmap-nostd-0.4): New variable.

Change-Id: Iea850c1ba463c2a980902ab7af9e78c708acb267
---
 gnu/packages/crates-io.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)
  

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index a55d6abb9e..0647be3f10 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -34760,6 +34760,27 @@  (define-public rust-indexmap-1.7
         ("rust-rand" ,rust-rand-0.7)
         ("rust-serde-derive" ,rust-serde-derive-1))))))
 
+(define-public rust-indexmap-nostd-0.4
+  (package
+    (name "rust-indexmap-nostd")
+    (version "0.4.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "indexmap-nostd" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "145mrkrrnzzg8xbv6si8j3b8cw1pi3g13vrjgf1fm2415gyy414f"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs (("rust-serde" ,rust-serde-1))
+       #:cargo-development-inputs (("rust-serde-derive" ,rust-serde-derive-1))))
+    (home-page "https://github.com/robbepop/indexmap-nostd")
+    (synopsis "no_std compatible implementation of the indexmap crate")
+    (description
+     "This package provides a no_std compatible implementation of the indexmap crate.")
+    (license license:asl2.0)))
+
 (define-public rust-indextree-4
   (package
     (name "rust-indextree")