diff mbox series

[bug#62684,v2] gnu: Zstandard: Update to 1.5.5.

Message ID cc2c81117ab887dc14e2a71cca0fb834563dfb70.1680973632.git.leo@famulari.name
State New
Headers show
Series [bug#62684,v2] gnu: Zstandard: Update to 1.5.5. | expand

Commit Message

Leo Famulari April 8, 2023, 5:07 p.m. UTC
This fixes a corruption bug:

https://github.com/facebook/zstd/releases/tag/v1.5.5

* gnu/packages/compression.scm (zstd)[replacement]: New field.
(zstd-1.5.5): New variable.
---
 gnu/packages/compression.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)

Comments

Leo Famulari April 12, 2023, 8:44 p.m. UTC | #1
On Sat, Apr 08, 2023 at 01:07:12PM -0400, Leo Famulari wrote:
> This fixes a corruption bug:
> 
> https://github.com/facebook/zstd/releases/tag/v1.5.5
> 
> * gnu/packages/compression.scm (zstd)[replacement]: New field.
> (zstd-1.5.5): New variable.

Pushed as 60c97c60a53686ec321eb541b85e01b6decc2014
diff mbox series

Patch

diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index e58fd65e49..1187d12421 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -1635,6 +1635,13 @@  (define-public unshield
 (define-public zstd
   (package
     (name "zstd")
+    ;; Replace to the data corruption bug fixed in Zstd 1.5.5.
+    ;; https://github.com/facebook/zstd/releases/tag/v1.5.5
+    (replacement zstd-1.5.5)
+    ;; Hide this buggy package in the Guix UI. If you add another
+    ;; property to this package, adjust the properties in the package
+    ;; replacement accordingly.
+    (properties `((hidden? . #true)))
     (version "1.5.0")
     (source
      (origin
@@ -1721,6 +1728,20 @@  (define-public zstd
                    license:public-domain ; zlibWrapper/examples/fitblk*
                    license:zlib))))      ; zlibWrapper/{gz*.c,gzguts.h}
 
+(define-public zstd-1.5.5
+  (package
+    (inherit zstd)
+    ;; Don't hide this package from the UI.
+    (properties '())
+    (version "1.5.5")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://github.com/facebook/zstd/releases/download/"
+                           "v" version "/zstd-" version ".tar.gz"))
+       (sha256
+        (base32 "1r1ydmj7ib3g5372yj3k40vl3b9ax0154qg2lqcy7ylwhb69chww"))))))
+
 (define-public pzstd
   (package/inherit zstd
     (name "pzstd")