[bug#75991,v2,2/3] gnu: tinygltf: Install a library.
Commit Message
Previously, only a static library would be produced and then deleted in a
phase.
* gnu/packages/graphics.scm (tinygltf) [arguments]: Add #:configure-flags.
<phases>: Remove delete-static-lib.
Change-Id: I019a87a4fbf68fc19270a41d58af3a2184b77215
---
gnu/packages/graphics.scm | 5 +----
1 file changed, 1 insertion(+), 4 deletions(-)
@@ -2611,6 +2611,7 @@ (define-public tinygltf
(build-system cmake-build-system)
(arguments
(list
+ #:configure-flags #~(list "-DBUILD_SHARED_LIBS=ON")
#:phases
#~(modify-phases %standard-phases
(add-after 'unpack 'use-our-packages
@@ -2623,10 +2624,6 @@ (define-public tinygltf
"stb_image_write.h")
(symlink (search-input-file inputs "include/catch.hpp")
"catch.hpp")))
- (add-after 'install 'delete-static-lib
- (lambda _
- (delete-file (string-append #$output
- "/lib/libtinygltf.a"))))
(replace 'check
(lambda* (#:key tests? #:allow-other-keys)
(if tests?