[bug#75991,v2,2/3] gnu: tinygltf: Install a library.

Message ID cc1128b3d539e3ec96fe291c172d9f115b35e820.1738478514.git.maxim.cournoyer@gmail.com
State New
Headers
Series [bug#75991,v2,1/3] gnu: tinygltf: Update to 2.9.3. |

Commit Message

Maxim Cournoyer Feb. 2, 2025, 6:42 a.m. UTC
  Previously, only a static library would be produced and then deleted in a
phase.

* gnu/packages/graphics.scm (tinygltf) [arguments]: Add #:configure-flags.
<phases>: Remove delete-static-lib.

Change-Id: I019a87a4fbf68fc19270a41d58af3a2184b77215
---
 gnu/packages/graphics.scm | 5 +----
 1 file changed, 1 insertion(+), 4 deletions(-)
  

Patch

diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 595e188de1..1492740f9c 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -2611,6 +2611,7 @@  (define-public tinygltf
     (build-system cmake-build-system)
     (arguments
      (list
+      #:configure-flags #~(list "-DBUILD_SHARED_LIBS=ON")
       #:phases
       #~(modify-phases %standard-phases
           (add-after 'unpack 'use-our-packages
@@ -2623,10 +2624,6 @@  (define-public tinygltf
                        "stb_image_write.h")
               (symlink (search-input-file inputs "include/catch.hpp")
                        "catch.hpp")))
-          (add-after 'install 'delete-static-lib
-            (lambda _
-              (delete-file (string-append #$output
-                                          "/lib/libtinygltf.a"))))
           (replace 'check
             (lambda* (#:key tests? #:allow-other-keys)
               (if tests?