diff mbox series

[bug#74411,v2,1/5] gnu: Add (gnu packages dictd).

Message ID cbf779e8e68e2e83ba03e386ef2da5355fa8a0a0.1732150157.git.runciter@whispers-vpn.org
State New
Headers show
Series [bug#74411,v2,1/5] gnu: Add (gnu packages dictd). | expand

Commit Message

Runciter Nov. 21, 2024, 12:49 a.m. UTC
* gnu/packages/dictd.scm: New file.
* gnu/local.mk (GNU_SYSTEM_MODULES): Add it.

Signed-off-by: Runciter <runciter@whispers-vpn.org>
---
 gnu/local.mk           |  2 ++
 gnu/packages/dictd.scm | 61 ++++++++++++++++++++++++++++++++++++++++++
 2 files changed, 63 insertions(+)
 create mode 100644 gnu/packages/dictd.scm


base-commit: b790db7589858fc77989b4d1f369c52bca6d6e7c
diff mbox series

Patch

diff --git a/gnu/local.mk b/gnu/local.mk
index a97e988add..7004d02547 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -67,6 +67,7 @@ 
 # Copyright © 2024 David Elsing <david.elsing@posteo.net>
 # Copyright © 2024 Ashish SHUKLA <ashish.is@lostca.se>
 # Copyright © 2024 Fabio Natali <me@fabionatali.com>
+# Copyright © 2024 Runciter <runciter@whispers-vpn.org>
 #
 # This file is part of GNU Guix.
 #
@@ -239,6 +240,7 @@  GNU_SYSTEM_MODULES =				\
   %D%/packages/decker.scm			\
   %D%/packages/dhall.scm			\
   %D%/packages/dico.scm				\
+  %D%/packages/dictd.scm			\
   %D%/packages/dictionaries.scm			\
   %D%/packages/diffoscope.scm			\
   %D%/packages/digest.scm			\
diff --git a/gnu/packages/dictd.scm b/gnu/packages/dictd.scm
new file mode 100644
index 0000000000..fed41def64
--- /dev/null
+++ b/gnu/packages/dictd.scm
@@ -0,0 +1,61 @@ 
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2024 Runciter <runciter@whispers-vpn.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages dictd)
+  #:use-module (guix packages)
+  #:use-module (guix gexp)
+  #:use-module ((guix licenses) #:select (gpl2+))
+  #:use-module (guix download)
+  #:use-module (guix build-system gnu)
+  #:use-module (gnu packages)
+  #:use-module (gnu packages autotools))
+
+(define-public libmaa-1.3.2
+  (package
+    (name "libmaa")
+    (version "1.3.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://sourceforge/dict/libmaa/"
+                           "libmaa-"
+                           version
+                           "/libmaa-"
+                           version
+                           ".tar.gz"))
+       (sha256
+        (base32 "1idi4c30pi79g5qfl7rr9s17krbjbg93bi8f2qrbsdlh78ga19ar"))))
+    (native-inputs (list libtool))
+    (arguments
+     (list
+      #:make-flags #~'("CFLAGS=-DHAVE_CONFIG_H  -Wall -Wno-error -g -O2 $(VERCFLAGS) -I. -I${srcdir}")
+      #:test-target "test"))
+    (build-system gnu-build-system)
+    (synopsis "Low-level data structures used by the dictd program")
+    (description
+     "The libmaa library provides many low-level
+data structures which are helpful for writing compilers, including hash
+tables, sets, lists, debugging support, and memory management.  Although
+libmaa was designed and implemented as a foundation for the Khepara
+transformation system, the data structures are generally applicable to a
+wide range of programming problems.
+
+  The memory management routines are especially helpful for improving
+the performance of memory-intensive applications.")
+    (home-page "https://sourceforge.net/projects/dict/")
+    (license gpl2+)))