diff mbox series

[bug#66030,v3,5/6] gnu: Add wcslib-7.12.

Message ID cbec61963b6e853ff3774d76ed2cc1dff414e8c2.1694977883.git.zimon.toutoune@gmail.com
State New
Headers show
Series [bug#66030,v3,1/6] gnu: openblas-ilp64: Add symbol suffix. | expand

Commit Message

Simon Tournier Sept. 17, 2023, 7:12 p.m. UTC
* gnu/packages/astronomy.scm (wcslib-7.12): New variable.
---
 gnu/packages/astronomy.scm | 16 ++++++++++++++++
 1 file changed, 16 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index e8499bb4b4df..402c09a6db4b 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -11,6 +11,7 @@ 
 ;;; Copyright © 2021 Foo Chuan Wei <chuanwei.foo@hotmail.com>
 ;;; Copyright © 2023 Iliya Tikhonenko <tikhonenko@mpe.mpg.de>
 ;;; Copyright © 2023 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2023 Simon Tournier <zimon.toutoune@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -741,6 +742,21 @@  (define-public wcslib
 header.")
     (license license:lgpl3+)))
 
+;;; The version is required for julia-wcs-jll and julia-wcs.  They do not
+;;; support version higher than 7.x.
+(define-public wcslib-7.12
+  (package
+    (inherit wcslib)
+    (version "7.12")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://www.atnf.csiro.au/people/mcalabre/WCS/"
+                           "wcslib-" version ".tar.bz2"))
+       (sha256
+        (base32 "1m3bx6gh5w3c7vvsqcki0x20mg8lilg13m0i8nh7za89w58dxy4w"))))
+    (properties '((hidden? . #t)))))
+
 (define-public weightwatcher
   (package
     (name "weightwatcher")