diff mbox series

[bug#66665] gnu: Add clifm.

Message ID cbde67b506d1de53edb172fe8c7974dbd3ed8047.1697878932.git.rodion.goritskov@gmail.com
State New
Headers show
Series [bug#66665] gnu: Add clifm. | expand

Commit Message

Rodion Goritskov Oct. 21, 2023, 9:02 a.m. UTC
* gnu/packages/clifm.scm (clifm): New variable
---
 gnu/packages/clifm.scm | 58 ++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 58 insertions(+)
 create mode 100644 gnu/packages/clifm.scm


base-commit: 8d6b3dd0b863ccada887da8cd347727dd04cb456
diff mbox series

Patch

diff --git a/gnu/packages/clifm.scm b/gnu/packages/clifm.scm
new file mode 100644
index 0000000000..b312ab7046
--- /dev/null
+++ b/gnu/packages/clifm.scm
@@ -0,0 +1,58 @@ 
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2023 Rodion Goritskov <rodion.goritskov@gmail.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages clifm)
+  #:use-module (guix packages)
+  #:use-module (guix gexp)
+  #:use-module (guix utils)
+  #:use-module (guix git-download)
+  #:use-module (guix build-system gnu)
+  #:use-module ((guix licenses) #:prefix license:)
+  #:use-module (gnu packages readline)
+  #:use-module (gnu packages acl)
+  #:use-module (gnu packages linux))
+
+(define-public clifm
+  (package
+    (name "clifm")
+    (version "1.14.6")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/leo-arch/clifm")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "15qrgj4kzxkc4lp3rpqvyk9ilc4nckrpiskg7y7p6bqr23n8chyh"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:make-flags (list (string-append "CC="
+                                         ,(cc-for-target))
+                          (string-append "PREFIX="
+                                         (assoc-ref %outputs "out")))
+       #:phases (modify-phases %standard-phases
+                  (delete 'configure)
+                  (delete 'build)
+                  (delete 'check))))
+    (inputs (list readline acl libcap))
+    (home-page "https://github.com/leo-arch/clifm")
+    (synopsis "Command line file manager")
+    (description "Shell-like, text-based terminal file
+manager that sits on the command line.")
+    (license license:gpl2)))