[bug#77187] gnu: tlp: Wrap sbin folder

Message ID cbcb339641be19ade9269e21dccae807a5a3993e.1742662512.git.rutherther@ditigal.xyz
State New
Headers
Series [bug#77187] gnu: tlp: Wrap sbin folder |

Commit Message

Rutherther March 22, 2025, 5 p.m. UTC
  Seems that tlp recently introduced sbin
folder, this has broken the wrapping for
tlp script. The tlp script can fail in
finding runtime dependencies.

* gnu/packages/linux.scm (tlp): Wrap sbin folder

Change-Id: Id006f21fb42e385dade732b9d237b045f3a863e7
---
 gnu/packages/linux.scm | 6 ++++--
 1 file changed, 4 insertions(+), 2 deletions(-)


base-commit: fbfd2b93831978aadbb96f32cafdab997b04c6c6
prerequisite-patch-id: cf473eb15513404ca1d287f5b7eca109c848203c
prerequisite-patch-id: a46e75bdd193acb5e276e0aa31c77197a3254699
  

Patch

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index b0dc6cbcfd..9bbed7c1df 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -8230,7 +8230,9 @@  (define-public tlp
           (add-after 'install 'wrap
             (lambda* (#:key inputs outputs #:allow-other-keys)
               (let* ((bin (string-append (assoc-ref outputs "out") "/bin"))
-                     (bin-files (find-files bin ".*")))
+                     (sbin (string-append (assoc-ref outputs "out") "/sbin"))
+                     (bin-files (find-files bin ".*"))
+                     (sbin-files (find-files sbin ".*")))
                 (define (bin-directory input-name)
                   (let ((p (assoc-ref inputs input-name)))
                     (and p (string-append p "/bin"))))
@@ -8260,7 +8262,7 @@  (define-public tlp
                                                 "pciutils"
                                                 "rfkill"
                                                 "wireless-tools"))))))
-                          bin-files)))))))
+                          (append bin-files sbin-files))))))))
     (home-page "https://linrunner.de/en/tlp/tlp.html")
     (synopsis "Power management tool for Linux")
     (description "TLP is a power management tool for Linux.  It comes with