diff mbox series

[bug#39201] gnu: Add r-deconstructsigs.

Message ID cbbddcb542a05e4bab5b1d86ab7e1654bb1c2afa.camel@gnu.org
State Accepted
Headers show
Series [bug#39201] gnu: Add r-deconstructsigs. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Roel Janssen Jan. 20, 2020, 7:32 p.m. UTC
Hi Ricardo!

On Mon, 2020-01-20 at 14:16 +0100, Ricardo Wurmus wrote:
> Hi Roel,
> 
> > Here's a patch to add r-deconstructsigs.  I added it to the cran module
> > because that's where it originates from, but it takes a reference
> > genome from bioconductor.  So I had to use the bioconductor module.  Is
> > that OK?
> 
> Please add the package to the bioconductor module instead and add a
> comment above to explain why.  (That’s what we’ve done for other
> packages like this.)

So I did.  Thanks for pointing this out.
I attached the new patch.

Thanks Ricardo!

Kind regards,
Roel Janssen

Comments

Ricardo Wurmus Jan. 27, 2020, 9:31 p.m. UTC | #1
Hi Roel,

sorry for the delay.  I pushed this to the master branch with commit
a38bf7c843.

Thanks!

--
Ricardo
diff mbox series

Patch

From 403a80754c3f53c29c4430cc5a537ee781cc9b1e Mon Sep 17 00:00:00 2001
From: Roel Janssen <roel@gnu.org>
Date: Mon, 20 Jan 2020 20:21:09 +0100
Subject: [PATCH] gnu: Add r-deconstructsigs.

* gnu/packages/bioconductor.scm (r-deconstructsigs): New variable.
---
 gnu/packages/bioconductor.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)

diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index ef34b99649..d4194e8ec2 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -694,6 +694,34 @@  annotations.")
      "This is a manifest package for Illumina's EPIC methylation arrays.")
     (license license:artistic2.0)))
 
+;; This is a CRAN package, but it depends on r-bsgenome-hsapiens-ucsc-hg19
+;; from Bioconductor.
+(define-public r-deconstructsigs
+  (package
+    (name "r-deconstructsigs")
+    (version "1.8.0")
+    (source (origin
+              (method url-fetch)
+              (uri (cran-uri "deconstructSigs" version))
+              (sha256
+               (base32
+                "014x0nb23jb98666kaav2phkvmkr38pi38jv0dqd4jv7zp0gdf1a"))))
+    (properties
+     `((upstream-name . "deconstructSigs")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-bsgenome" ,r-bsgenome)
+       ("r-bsgenome-hsapiens-ucsc-hg19" ,r-bsgenome-hsapiens-ucsc-hg19)
+       ("r-genomeinfodb" ,r-genomeinfodb)
+       ("r-reshape2" ,r-reshape2)))
+    (home-page "https://github.com/raerose01/deconstructSigs")
+    (synopsis "Identifies signatures present in a tumor sample")
+    (description "This package takes sample information in the form of the
+fraction of mutations in each of 96 trinucleotide contexts and identifies
+the weighted combination of published signatures that, when summed, most
+closely reconstructs the mutational profile.")
+    (license license:gpl2+)))
+
 (define-public r-do-db
   (package
     (name "r-do-db")
-- 
2.25.0