[bug#76513,rust-team,27/77] gnu: Add rust-dirs-6.

Message ID cb8605f5ef69047d62bc6fe1dc9b4578642bc636.1740340805.git.wongandj@icloud.com
State New
Headers
Series Add module (gnu packages typst) and packages |

Commit Message

Andrew Wong Feb. 23, 2025, 8:21 p.m. UTC
  * gnu/packages/crates-io.scm (rust-dirs-6): New variable.

Change-Id: Ica344d9980b6c936564552d233de498f5d8bd37a
---
 gnu/packages/crates-io.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)
  

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 8f47028b26..1776bd44f4 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -21328,6 +21328,32 @@  (define-public rust-directories-next-2
 other data.")
     (license (list license:expat license:asl2.0))))
 
+(define-public rust-dirs-6
+  (package
+    (name "rust-dirs")
+    (version "6.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "dirs" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "0knfikii29761g22pwfrb8d0nqpbgw77sni9h2224haisyaams63"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:skip-build? #t
+       #:cargo-inputs (("rust-dirs-sys" ,rust-dirs-sys-0.5))))
+    (home-page "https://github.com/soc/dirs-rs")
+    (synopsis
+     "tiny low-level library that provides platform-specific standard locations of directories for config, cache and other data on Linux, Windows, macOS and Redox by leveraging the mechanisms defined by the XDG base/user directory specifications on Linux, the Known Folder API on Windows, and the Standard Directory guidelines on macOS.")
+    (description
+     "This package provides a tiny low-level library that provides platform-specific
+standard locations of directories for config, cache and other data on Linux,
+Windows, @code{macOS} and Redox by leveraging the mechanisms defined by the XDG
+base/user directory specifications on Linux, the Known Folder API on Windows,
+and the Standard Directory guidelines on @code{macOS}.")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-dirs-5
   (package
     (name "rust-dirs")